jenerator

Laptop will not correctly install/recognise drivers

Discussion created by jenerator on Sep 8, 2018
Latest reply on Sep 11, 2018 by elstaci

System details

  • AMD Graphics Card
    • AMD R9 M290X

Desktop or Laptop System

    • Laptop MSI GX60 Destroyer 3CCC
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • AMD Radeon(TM) HD 8970M, date 22/09/2017, version 22.19.667.257
    • AMD Radeon HD 8650G, dated 22/09/2017, version 22.19.677.257
  • Motherboard + Bios Revision
    • American Megatrends Inc E16FKAMS.D0K 2/12/2013
  • CPU/APU
    • AMD A10-5750M APU with Radeon HD graphics, 2500 mhz, 4 cores, 4 logical processors.
  • RAM
    • 16GB

Describe your issue:

Let me start by saying I am not a super tech savvy person so my explanations and the details above may seem a little basic and lacking information.

 

I have recently started gaming on my laptop again (WoW). At first I wasnt able to play WoW but after uninstalling, downloading and fiddling with my drivers I finally got it to work smoothly with all Blizzard games... until last week. I was playing without issue one night and the next night some how everything changed and now I cannot play any games. I cant actually remember what I did the first time so for the life of me I cant seem to fix it again. I have done a fair bit of research on my problems but i cant seem to find a solution which is why I am here.

 

From my research I believe the issue lies in my Legacy drivers not working correctly/my laptop is not recognising them correctly although as I said im not very tech savvy so I could be way off.

 

First of all my DXDIAG shows my driver is a microsoft basic display driver:

However my Device manager shows 2 AMD drivers.

The 8970G is working properly but the 8650G has no drivers installed:

 

The whole reason I realised I had a problem was when I try to start wow the blizzard app brings up a message saying "WOW was unabled to start up 3D acceleration" which I also cannot find any solutions for that work.

 

So I guess my question is a 2 parter - How do I get the 8650G to work properly and how do i get my computer to recognise these drivers in the DxDiag?

 

Thanks in advance for any help.

Outcomes