3 Replies Latest reply on Nov 30, 2018 9:01 AM by mrup

    xfx rx 580

    jrae2424

      Upgraded to an RX 580 8gb from an RX 470 4 gb.  I've had no issues with the 480, can play most games on high settings with a good frame rate, no issues.  After installing the 580 I started getting a flashing black screen while gaming.  This would start around after 5 to 10 minutes of gaming.  The screen would go black for a few seconds then come back.  Sometimes it would flash a few times each instance.  Reinstalled the rx 480 and everything is back to normal. Any ideas?

        • Re: xfx rx 580
          pokester

          Yes, in Radeon Settings / Gaming / Global Settings / Global Wattman / :  Find the power limit slider down below the fan settings. Move it all the way to the right to it's max. Likely 50 on the RX 580. This should help, very common issue on the RX 580's that you need to raise the power ceiling. Most the cards sold are overclocked cards and the drivers are for reference versions so most cards just need a higher ceiling.

          1 of 1 people found this helpful
          • Re: xfx rx 580
            mrup

            Same problem for me. I switched to HDMI and it works fine however, there's no free-sync. I found drivers for my monitor from LG and that helped but still not usable. Today I plan to try increasing the voltage. Your post was a couple months ago. Did you find resolution?

              • Re: xfx rx 580
                mrup

                This AMD site shows how to setup WATTMAN: OC+ for many cards... including my RX580 OC+

                This provided me the best performance, but it's now obvious my UltraWide LG 2560x1080 monitor is too much for this card to handle with free-sync... or it could be the monitor is too old and needs a beefy card like VEGA56 or VEGA64.

                 

                If I want to use this card, i cannot use the DisplayPort... even if I disable Free-Sync and GPU scaling, the screen still flashes on/off and a 1 inch horizontal bar appears occasionally. Just switching to HDMI solves the problem.

                 

                I still like the card but I'll switch it to another PC that has another monitor.