1 Reply Latest reply on Aug 30, 2018 9:27 AM by kingfish

    Driver gone from device manager and AMD Settings just doesn't launch

    daxy

      Ok, I dont know what to do. I have a HD8970M and I had driver 18.5.1. I updated to 18.8.1 and the amd setttings said that I didnt have any driver at all. In device manager, the driver was there but there was an error sign over it. I downloaded just the 18.5.1 driver and that fixed it but then I updated to 18.8.2 because I thought they patched the bug. When I updated the driver it was the same story but this time when I clicked on the driver installer it said error 175, that I didnt have the right hardware. Im completely lost. What replaced my AMD Driver in device manager is the Intel HD graphics 4600. Ive deleted that driver before and it came back. Please if someone could help.

       

      Update: I tried to re-download the 18.8.2 driver and see if that works, it gave me Error 173 which means that I dont have any amd hardware. So driver 18.5.1 says that I have incompatible hardware and driver 18.8.2 says that I just dont have hardware.