3 Replies Latest reply on Aug 30, 2018 2:28 PM by tallen

    cannot upgrade to threadripper 2990x from 1950x

    tallen

      I cannot get past "cpu" stage when booting up after replacing the 1950x with the new 2990x threadripper2. Granted I do not have the graphics card plugged in but I know from experience that as soon as it gets to 'cpu' I get an immediate shutdown and I need to look no further. I can also put back my 1950x and get back up and running without issue. Tired of doing this and hoping my new TR2 is not d.o.a. Any ideas? Here's the rest of system: I believe I'm fully compatible

       

      Mobo:

       

      ASUS ROG ZENITH EXTREME sTR4 AMD X399 SATA 6Gb/s USB 3.1 Extended ATX AMD Motherboard

       

      Power:

       

      EVGA SuperNOVA 1000 G2 120-G2-1000-XR 80+ GOLD 1000W Fully Modular Includes FREE Power On Self Tester Power Supply

       

      Ram:

       

      CORSAIR Vengeance LPX 16GB 288-Pin DDR4 SDRAM DDR4 3000 (PC4 24000) Desktop Memory Model CMK16GX4M1B3000C15

      (64GB)

       

      Liq Cooler: (on the AMD TR2 cooler list)

       

      Enermax Liqtech TR4 360 AIO Liquid CPU Cooler, Support 500W+TDP and Overclocking, AMD Socket TR4 Ready, ELC-LTTR360-TBP
      Graphics:

       

      EVGA GeForce GTX 1080 Ti FTW3 GAMING, 11G-P4-6696-KR, 11GB GDDR5X, iCX Technology - 9 Thermal Sensors & RGB LED G/P/M

       

        • Re: cannot upgrade to threadripper 2990x from 1950x
          tallen

          Adding to my own thread. I did update the bios via asus support. However as soon as I run something that uses all cpus I flat out crash. Is anyone else experiencing this?

            • Re: cannot upgrade to threadripper 2990x from 1950x
              elstaci

              By any chance did you install the AMD Ryzen Master for your Ryzen 2990x?

               

              Here is the download page where you can install it. AMD Ryzen™ Threadripper™ 2990WX Drivers & Support | AMD .

               

              Seems like you need to use Ryzen Master to configure your Ryzen 2990X CPU.

                • Re: cannot upgrade to threadripper 2990x from 1950x
                  tallen

                  Thanks, yes I downloaded. Turns out my problem is compound. Not solved yet and so I'll post another thread about overheating and throttling shortly. But thanks for your recommendation. It was a help for sure. Before that, I was using 'AI Suite3' from ASUS (since my mobo is a ROG Zenith Extreme).... both applications are pretty good, but feeling better with Ryzen Master for sure.

                   

                  Followup: Still want to mention. Big shout out to support from ASUS as well.... the big problem was I never downloaded the updated BIOS for the new chip. That's why I was immediately crashing at boot up. That was the game changer right there. Must say, I was pretty impressed by being able to plug in a fat32 formatted usb (complete with the renamed ZE.CAP file) into the 'BIOS Flashback' slot on the back panel of my rog zeinth extreme mobo, and then by simply pressing the 'BIOS Flashback' button (and secondly, clearing custom bios settings afterwards by pressing the CMOS button, and clearing startup memory). It sure helps. I thought I was going to have to reinstall my older threadripper 16-core just to upgrade the bios.

                   

                  Thanks again for your advice!