11 Replies Latest reply on Oct 10, 2018 3:51 PM by searon9

    troubleshooting a reinstall of a 1950x

    searon9

      I had some problems with my motherboard.  My first install of my 1950x went off without a hitch.  On the second install however, I accidently knocked the chip out of its carrying handle when cleaning thermal paste off of it.  It did not work on the second install.  It only dropped a few inches, so its probably fine, but it may not be properly seated in the carrying handle or in the motherboards socket.  I put it back in the carrying handle oriented in the proper direction and kept touching the case to discharge static electricity.  I then cleaned the whole thing with cotton balls and alcohol to remove hand grease, being carefull not to leave behind any cotton.  The motherboard turned on, but would not post.  The motherboard was tested before it left the factory, so i dont think it is the motherboard.  I then cleaned the entire chip and its seat with compressed air.   still i had the same problems.  this whole time it took more pressure to screw down the chip than it did during the original install, making me think its improperly seated, perhaps a little low in the seat.  Is there a way to fix this?

        • Re: troubleshooting a reinstall of a 1950x
          elstaci

          If you dropped the CPU a few inches, need to check very closely, use a magnifying glass, and see if any of the tiny pins were bent.

           

          Were you using Non-conductive Thermal Paste?

          • Re: troubleshooting a reinstall of a 1950x
            misterj

            searon9, there are two TR4 socket vendors that I have experienced.  My first MB had the 'good' socket with the correct length screws that started and tighten properly.  My RMA MB came with a 'bad' socket.  The screws seemed to be too short, were hard to start (required pressure) and did not seem to tighten properly.  Please be sure to use the torque driver that came with your processor.  Carefully examine (with magnifier) the pins in the socket for bent pins.  I strongly recommend that you take several pictures of your socket (enlarged) and several of your processor and plastic handle/bracket.  Please open an AMD e-mail ticket via the AMD Online Support Request, attach the pictures (suggest all in a folder then compress).  Describe what happened and ask them for help.  Also post the pictures here.  Perhaps someone here has faced your dilemma.

            elstaci, Threadripper sockets have the pins the processor has a LGA.

            Enjoy, John.

            1 of 1 people found this helpful
              • Re: troubleshooting a reinstall of a 1950x
                elstaci

                Here is an old previous Thread from AMD Forums where a User was having difficulties installing a Ryzen 1950X CPU. amdmatt gave the correct answer by linking a You-tube video showing how to install the CPU in a Asus Motherboard. Ryzen Threadripper 1950X Won't Screw Into Socket - ASUS ROG Zenith Extreme X399 Motherboard .

                 

                The correct answer to the post copied from the link:

                 

                amdmatt

                Correct Answerby amdmatt Employee on Nov 30, 2017 12:41 AM

                Installation tutorial, key is to turn each screw half a thread initially to allow it to thread.

                Ryzen Threadripper 1950X Processor installation guide on X399 Zenith ASUS motherboard - YouTube

                 

                but another User indicated that this was the correct answer in the same thread:

                 

                Re: Ryzen Threadripper 1950X Won't Screw Into Socket - ASUS ROG Zenith Extreme X399 Motherboard

                pisymbol

                I just want to thank everyone for this thread. I got it, it POST'ed the very first shot with no issue!

                 

                However, two post mortem observations:

                 

                - All of the install videos on YouTube are just flat out wrong. In every one of them I see the person gently close the tray cover and just leisurely torque down screw #1. This leads me to believe that the review units must have had screws longer than the ones they shipped with in the retail boxes or something else was afoot.

                 

                - For those out there that find this thread: Don't get discouraged. It's not you, it really is them! My advice is don't be afraid to apply firm pressure straight down once you are sure the screw is aligned with the threads (and by firm I mean "hard").  Obviously, you don't want to break the board so be judicious. Part of the reason why it took me so long is I would apply incrementally more and more pressure until I reached my "reasonable" threshold which apparently was a lot less than what was needed. It was only until I was pointed to this thread (from the Asus ROG board) that I knew I had to push even harder. Yikes. It worked though.

              • Re: troubleshooting a reinstall of a 1950x
                searon9

                I finally solved my problem.  It turned out that the motherboard was having problems.  12V was spiking up at 18 volts for no reason.  and several other problems were occuring.  First, I had the memory sticks in the wrong 4 out of the 8 slots.  This showed up as a cpu error by its trouble light instead of a memory error.  Also the error code on the digital display at the bottom of the aorus x399 motherboard was showing 36, a code for reserved error.  Not a memory error.  The chip was replaced regretably, as it probably only had cosmetic defects in it.  The moitherboard was returned twice and replaced after the second return.  It was tested after the first return, but apparently, they did not check to see if BIOS kept resetting every boot.  Everything but the clock was resetting every reboot.

                  • Re: troubleshooting a reinstall of a 1950x
                    elstaci

                    Very rare that you would get two bad motherboards. With computers anything can happen.

                     

                    Could your PSU have been causing the power problems with the motherboard or possibly causing your Motherboards to be damaged?

                     

                    Anyway, If replacing the Motherboard solved your problem. Might as well "Mark" your last Post as "CORRECT" so others will know it was a hardware and not a software problem.

                     

                    Glad to hear you finally got it fixed.

                     

                    Just for my own information, Who was the Manufacturer of the two defective Motherboards?

                    1 of 1 people found this helpful