24 Replies Latest reply on Aug 13, 2018 5:10 PM by johndrakak

    18.8.1 killed my RX 580 ?

    johndrakak

      Greetings everyone,

       

      My current setup:

      ItemType
      CPUAMD FX 6300
      MotherboardGigabyte GA-970A-D3 rev.3.0
      GPUSapphire RX 580 Nitro+ 8GB
      RAMTranscend 2x4GB 1333MHz
      OSWindows 10 Home Ver 1803 64-bit
      GPU drivers before updating18.7.1

       

      This morning I received a notification from the Radeon software that a new version of my drivers is available and so I clicked at Express Install.

       

      While the driver was being installed I was watching some random Youtube videos, 3 times during the installation the computer froze for less than 5 seconds which seemed weird but didn't worry me that much, so I let it finish normally.

       

      But when the installation finished my screen turned FULL pink!

      I reset and when Windows fully loaded after about 10-20 seconds my screen turned to pink again, or some other color not sure.

       

      I thought a clean installation was the way to go and so:

      • Downloaded and installed DDU,
      • Boot in safe mode and uninstall current drivers,
      • I installed 18.5.1 cause it was indicated as a stable release.

       

      But even with the 18.5.1 the same thing happened, after 10-20 seconds the screen turned black or any other color. (Also tried clean installing 18.7.1 and 18.8.1 again).

       

      The card's warranty was active so I went to the store I bought it from and they told me that they'll contact Sapphire about a replacement cause from what I explained to them the card must have died.

       

      What frightens me now is that a simple driver update could kill my GPU ...

      What're your thoughts on my situation?

       

      Thanks in advance.

      -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

      UPDATE as of August 13th

       

      Got a call from the vendor that the card was back and just fine and that the problem must be somewhere else.

       

      On my way home stopped by a friends house just to check the card on his PC, with the usual safe mode / no internet / DDU procedure, installed drivers and it worked just fine. So I was 100% sure that the card was fine, but my PC had some personal issue with the card.

       

      When I returned home:

      • first thing I check was running the card with only the 2x6-pin power connectors instead of a 6-pin and an 8-pin, still not working.
      • changed the whole PSU with another one I had, still not working.

      So the only thing left to check was the Windows installation and so i began the formatting process and since then it works like a charm.

       

      In the end, the problem was lying with the Windows, what I can assume is that during the driver installation where I was messing around (watching videos etc), something must have screwed up and like blacklisted my RX580.

      The really weird thing with my issue so far is that this behaviour was only seen with my RX580, because in one of my tries when the RX580 blacked out I immediately replaced with my HD 7790 WITHOUT clean installing drivers or anything and it worked just fine, and this was the reason I didn't believe it was a Windows issue.

       

      I want to thank everyone in this forum for your posts and assistance, I am really grateful for your response.

       

      Issue resolved.

        • Re: 18.8.1 killed my RX 580 ?
          goodplay

          User error.youtubeCapture.PNG

          2 of 2 people found this helpful
            • Re: 18.8.1 killed my RX 580 ?
              johndrakak

              You mean this activity could be the culprit of my dead GPU, I know it's not advised or recommended to do so, but affecting the hardware in that degree ....

                • Re: 18.8.1 killed my RX 580 ?
                  goodplay

                  Until you hear back from sapphire, it's not known yet if the card/components have a failure.

                  There is probably a very long & technical whitepaper on what can go wrong when trying to install drivers with, in your case video content running (and perhaps multiple other apps/webpages open/minimized ?). Or perhaps the card already had a faulty component ?

                  There may even be a possibility of a power spike to the card (driver safety functions corrupted/disabled ?), by the way, what is the make/model/watts(how old) of your psu.

                  2 of 2 people found this helpful
                    • Re: 18.8.1 killed my RX 580 ?
                      johndrakak

                      The PSU is a 750 Watt made from a local manufacturer to my country it's not something fancy but I've been working with it for the past 5 years and didn't have any issues.

                       

                      Let's hear what Sapphire has to say I'm really curious, but it's gonna take a while for them to respond, the vendor told me about 15-25 days.

                       

                      Thanks for your time !

                • Re: 18.8.1 killed my RX 580 ?
                  locodicegr

                  No the driver didnt kill your card is the answer.

                  • Re: 18.8.1 killed my RX 580 ?
                    theacclaimed

                    You shouldn't be running any application that uses the GPU for rendering such as watching videos while doing a driver update. The card is fine. You probably have something messed up in the Windows registry and have to roll back windows to the time before the driver was installed.

                     

                    The installer even says to make sure to close any other running applications before attempting the update.

                    • Re: 18.8.1 killed my RX 580 ?
                      colesdav

                      1. What drivers do you see in Control Panel -> Hardware&Sound -> Device Manager -> Display Adapters.
                      Here is an example:

                       

                      • Re: 18.8.1 killed my RX 580 ?
                        colesdav

                        Hi,

                        In summary this is what I did that worked.

                        Download a fresh copy of the appropriate 18.8.1 driver from AMD Drivers download page first. Put it on your windows desktop so you can run it quickly.
                        Set up Windows Update (if you can in Windows 10 home) so that it will not install any drivers using local group policy. Pause & Defer updates.

                        Turn off your router to your house/building/room/ so there is no way your machine can connect to the internet via wireless or cable connection.

                        Then uninstall AMD Driver in control panel.

                        Then boot into safe mode.

                        Then run DDU to uninstall and AMD Drivers. You should also run the Nvidia driver uninstaller as well ... just in case.
                        Reboot into normal mode.
                        Go to Control Panel -> Hardware&Sound -> Device Manager -> Display Adapters. Make sure you see Microsoft Basic Display Adapter.

                        Install the AMD 18.8.1 driver using the Driver installer you placed on the desktop as quickly as possible (within 2 minutes of logging in - just in case, somehow, your machine can connect to the internet). 

                        Reboot your machine.

                        See if that works.

                        Bye.

                          • Re: 18.8.1 killed my RX 580 ?
                            johndrakak

                            This is pretty much the proccess I followed when I clean installed the different versions, had all 3 setup files ready (  18.5.1 / 18.7.1 / 18.8.1 ), had turned off my router, had hidden the Windows updated with a tool I download from Microsoft "wushowhide.diagcab".

                            The issue persisted nonetheless.

                             

                            At the moment I don't have the card at hand, it's on it's way to Sapphire.

                            Thanks for your time!

                            1 of 1 people found this helpful
                              • Re: 18.8.1 killed my RX 580 ?
                                colesdav

                                Hi,

                                 

                                Thanks - no problem.

                                Since you disconnected from the internet during amd driver install I do not think you will have any issue with Microsoft sneaky AMD Driver install then you overwrite with the downloaded AMD Driver. 

                                 

                                FYI - Microsoft "wushowhide.diagcab", Group Policy prevent driver install, pause updates, control panel advanced options-do not install drivers, and defer updates, DDU in safe mode and reboot  are doing nothing to prevent  one of my  Microsoft Windows 10 Pro 64bit 18.04 CBB installations from installing the wrong  AMD Driver  (AMD Settings 17.1.1 + 17.4.4 drivers) on one of my PC with R9 Fury X and R9 Nano. In addition the Adrenalin 18.8.1 Installer does not even see the Microsoft AMD drivers have been installed. It  simply installs over them. AMD's own installation notes warn users not to do  this as it will result  in a corrupted driver.

                                 

                                The above issue is difficult to catch.

                                 

                                The only way I have found that  works is to disconnect my Router so there is no way Windows 10 can connect to the internet.

                                 

                                I cannot wait for the day  when all  devices  are  permanently connected to 5G.

                                 

                                I hope the RMA goes well.


                                Bye.

                                1 of 1 people found this helpful
                                  • Re: 18.8.1 killed my RX 580 ?
                                    johndrakak

                                    So the only recommended action during a clean installation is to have the PC disconnected from the internet, to prevent Windows installing false drivers ?

                                     

                                    Thanks again.

                                    • Re: 18.8.1 killed my RX 580 ?
                                      kingfish

                                      DDU was the first to notify us that disconnecting from the internet is required now, as Microsoft changed/did something to the automatic update feature.

                                      DDU has new instructions..make sure you have the latest version

                                      2 of 2 people found this helpful
                                        • Re: 18.8.1 killed my RX 580 ?
                                          colesdav

                                          Yes, I understand, I saw the DDU notes, but I hit the problem before that post was up.

                                           

                                          After running DDU in safe mode I boot into Windows 10 Pro 18.03 in Normal mode.

                                           

                                          I have one Windows 10 Pro 18.04 64bit installation that, when I reboot into normal mode, no  Group Policy setting I can find will prevent Microsoft from Installing the wrong AMD 17.1.1 Radeon Settings + 17.4.4 Drivers which are not even supposed to work with 18.03.

                                           

                                          I have removed C:\AMD, run off a single primary disk, made sure no amd driver traces are anyhere on the C: drive. 

                                           

                                          If I didn't notice that Microsoft had put those drivers on there (it is easy not to notice).

                                          I can then run the Adrenalin 18.8.1 installer and it doesn't even report that AMD Crimson 17.1.1 is running on the same screen whilst the installer runs.
                                          This situation is ridiculous and is very likely causing many people to have corrupted driver installations.

                                           

                                          I have to physically turn off my Router now to make sure my AMD Drivers can install cleanly now.

                                           

                                          FYI the 'wrong driver'  is nothing to do with Crossfire or DDU.
                                          I tested on another Windows 10 Pro 18.03 installation and machine with a single AMD card, an R9 Nano, in the secondary PCIe slot.

                                           

                                          This time I uninstalled existing 18.7.1 driver. using the normal recommended method using control panel, rebooted, deliberately set Windows 10 Group Policy to allow install of drivers , ran Windows Update (connected to the internet) , and Windows installed the same 17.1.1 Radeon Settings with 17.4.4 drivers. Again I ran the Adrenalin 18.8.1 installer to see if it would even detect the Microsoft Installed AMD Crimson ReLive 17.1.1 Radeon Dettings + 17.4.4 driver. It doesn't.


                                          Thanks.

                                  • Re: 18.8.1 killed my RX 580 ?
                                    srs13rastus

                                    Been having issues with 18.8.1 not applying the correct default VRAM speed on my Vega 64 No matter what speed I set the VRAM to it always drops to the minimum speed shown in global wattman (800MHz yet the card's default is actually 940MHz).

                                    Wattman will only apply the correct speeds if I set it manually to 940 or my chosen overclock of 1040 and LEAVE WATTMAN OPEN at all times.

                                    Closing wattman causes it to apply 800MHz.

                                    Thanks to this issue I've had multiple CTD's and freezes requiring a hard reboot.

                                     

                                    If you're on 18.8.1 check the ram settings in wattman, if this shows as the minimum then use DDU and go back to 18.7.1 or WHQL 18.5.1....

                                    Vreated my own thread about this problem here 18.1.1 memory defaults to 800MHz on Vega64

                                    • Re: 18.8.1 killed my RX 580 ?
                                      goodplay

                                      Good to see your card back and running, just noticed your first post edit.