0 Replies Latest reply on Aug 6, 2018 6:36 PM by thanatos

    rx470 crash under sustained load

    thanatos

      This is an issue I've been having since I got my rx470, and I can't find it anywhere online. In windows 10, under a heavy, sustained load, the output signals will randomly cut out. When this occurs in a game, some of the audio will continue to play, though the game does not continue to run correctly. For example, this happened in the Witcher 3 during the first cutscene with in-engine assets. The background music continued to play for a while, but the dialog of the cutscene did not advance. Once the music ran off the end of the cutscene, it switched to random noise. Other games will do similar things, and NUMLOCK/CAPSLOCK on my keyboard stop working. This indicates a complete crash of Windows as far as I can tell.

       

      I believe that the root cause of the issue is a driver bug or an incorrect setting in Windows. Running FurMark on windows will cause it to crash after a few minutes. Doing the same on Linux with the open source amdgpu drivers, I let it run for ~half an hour without incident. Temps were far from concerning in both runs (~75 max). Additionally, I have run some games on both platforms, and have only seen any sort of crash in Windows. This leads me to rule out the hardware, though if there still may be an issue there that only affects Windows, please let me know.

       

      My hardware:

       

      600W PSU

      Intel Xeon x5690 (same issue existed with w3530)

      18GB DDR3

      XFX RX 470 4GB SF in a x16 PCIe2.0 slot

       

      Windows 10 and the AMD Catalist drivers are up-to-date, and all versions in the past 2 years have had this issue.

       

      Has anyone else encountered this issue?