AnsweredAssumed Answered

Issues with access violations

Question asked by ahall1983 on Aug 3, 2018
Latest reply on Sep 7, 2018 by evastonian

Hey there folks I dunno if anyone has any ideas I'm really hoping this is software but at the same time I'm pretty much out of ideas as I've talked on other forums, and to AMD's support as well but I don't know what to do here. I'm so tired of doing tech support right now I have the biggest headache over it. So my old PC I was not ready to replace but it died and it HAD to be replaced, so I built a new one out of savings trying not to cut too many corners but leave room to upgrade. This new PC is pretty great... when it works right, and that's the problem, it's not. I'll see if I can remember everything I've done but I've had it about a month so I've been fighting with quite a bit, there's too many things to forget!

 

This new machine has the following stuff:

Asus x370-A Prime motherboard, newest bios

Ryzen 1800x

Corsair RAM DDR4 16 gb (2x 8gb sticks) 2666 Mhz (I'd have to look up the model, but it's on QVL)

EVGA Geforce GTX 1060 6gb

Crucial 250gb SSD M.2

WD 1TB HDD

Corsair CX650M PSU (650w)

 

So I'm grasping at straws for what's wrong. This PC in general is usually working fine, however it's the intensive programs like games that are the issue. I'm guessing 0xc0000005 general protection fault crashes (regular crashes, not BSOD level) frequently .While my older stuff is generally fine, the newer stuff is not. Star Trek 's never crashed it, Guild Wars 2.... I was saying it hadn't but it just did a little ago, Warframe, Batman Arkham Knight (which is already a terrible PC port) and Deus Ex Mankind Divided however do it frequently. In Batman's case the game won't stay running longer than 5 minutes in most cases, Deus Ex is random, sometimes it works for a while, sometimes it's a 5 min thing (I think it crashes on autosave, and actually that might be the case on Batman also, but not sure why.) Honestly as far as Batman goes, I'd like to play it but I know that's such a bad PC port there's plenty of people that have still never gotten it to work right.

 

I'm just stumped to what's doing this. I've ran benchmarks that don't fail. I've ran Memtest86 and the windows memory test which don't find anything wrong with the memory. I've done the usual sfc/dism/chkdsk to no avail. I've had probably 5-8 driver versions of Nvidia's drivers in here (honestly if it's a software thing I fully suspect them as the QA on their drivers has gotten more than a little terrible in recent years) as for the Nvidia drivers I did use DDU to blow those out in numerous cases, I'm quite familiar with that tool. As for other general drivers as far as I know, they should be up to date I installed stuff fresh from the company sites when I built this in just the last month. I'd done quite a bit with the video driver too, I often suspect Nvidia quite a bit these days. I had tried various builds, I'd tried installing the driver only without the extras especially PhysX, but no dice. Oh, and it's not overheating, either, not even close.

 

As for the RAM, it's in the recommended slots on the motherboard, I've also tried one stick, I've tried juggling them, it doesn't matter the crashes persist. I also didn't have DOCP turned on when I originally made this yet, so it ran at 2133mhz for over a week fine, and I've got DOCP now, running it at it's full expected 2666Mhz but it makes no difference, the errors still occur.

 

I'm also aware of the Ryzen batches that had the segmentation faulting issue that was mostly seen on Linux, I already contacted AMD's support though and they checked the serial number and said it shouldn't be in that batch, so I should have a good one, unless it's just broken. I'm also not sure if the board itself can be involved in that? Maybe? I hope it's not the board, cripes, this PSU power plug has such a death grip I'm afraid of how I'll replace it in the future.

 

I did contact AMD's email support, unfortunately they weren't very helpful. He wanted me to go try the CPU in another machine and would RMA it if it did it on another one. While the attic is full of old computers, everything's pretty outdated by the time I replace them, (or like the old one, they break down and even then it wasn't AM4) I don't have another AM4 machine to test anything in so if it is the CPU somehow I really hope that trying it in another machine that costs $200+ to make, which I don't need, isn't going to be a warranty contingency here. As much as I wish I could just do that to test it out and make this all less of a headache, I just don't have another AM4 PC or the money, or need, for one right now.

 

This is just kinda killing me here. I really didn't have the money to be building this in the first place and had to use savings to do it because I can't sit here going stir crazy with nothing to do (and actually to make matters worse my TV broke while waiting on parts to make this new one, how about that timing, and we have no cable TV anyway lol ) My old PC, the PSU blew, I dropped a new one in (the one in this new PC now actually) and it came back, and worked fine for a few days, but then it started doing hangs and BSODing all the time, and it got increasingly worse. When that PSU blew though, it didn't just stop turning on, it stopped working when the PC was at a high load gaming and broke down, so I'm not sure it didn't damage anything. But, I was doing nothing but tech support at home for like 2 weeks trying to fix the stupid thing, eventually, it got to the point that it was hanging outside of Windows prior to boot and that was close to the final straw on that once I realized it couldn't possibly be software related or the disk. The old PC I'd been upgrading since 2009, so it wasn't really in a good place to be repaired, so I had to shell out on this new one, which I really didn't have money to be making, but I needed to make a reasonable foundation to upgrade in the future, ya know?

 

I was floating the idea that the PSU might not be working right seeing as the old PC didn't work right with this new one either. But I dunno, I'm just not really convinced unless someone else knows more about it than I do. As for wattage, 650 watt should be enough for this, I even ran my parts through various PSU calculators before deciding on the final build instead of eyeballing it. I did hear some shaky things about this PSU after buying it. At the time, I was just so distraught trying to get the PC repaired that Corsair's was what was available locally quickly, usually a reasonable brand, and had a general 4/5 star rating on it, but later on I found out there's a green and gray tagged version of this PSU and the earlier green printed ones were crappy build quality, mine's gray though, I hope it's ok but I don't know. Is it possible for voltage changes to cause an access violation of some kind? I really don't know. Either way if it's hardware, and it may very well, it this is already shaping into a massive headache especially if I gotta get that PSU off of this board haha... ugh... Seriously though, Corsair's board power supply plug has a death grip.

 

Anyway sorry for the verbose spiel, thanks for any ideas or help anyone can provide

Outcomes