15 Replies Latest reply on Jul 31, 2018 9:46 AM by shibble

    Ryzen 7 2700x no display on boot

    shibble

      Hi, I have  a Ryzen 2700x with a Gigabyte gaming k7 motherboard.

      When I boot the computer the fan on the cpu spins as does the fan on the gpu.

      The problem is I cannot get the computer to output to the display, I get an error code of 02 on the motherboard, that code is not listed in the motherboard manual.

      Any help would be greatly appreciated.

      Ian

        • Re: Ryzen 7 2700x no display on boot
          arcticwind

          Is your motherboard the GA-AX370 Gaming K7 motherboard?

          If so, is the BIOS updated to support the Ryzen 7 2700x processor? (F22 BIOS)

          INFORMATION REQUIRED WHEN POSTING A QUESTION

            • Re: Ryzen 7 2700x no display on boot
              shibble

              First of all thank you for the quick reply. Yes that is my motherboard and it has been updated with the latest bios.

               

               

              Sent from my Samsung Galaxy smartphone.

                • Re: Ryzen 7 2700x no display on boot
                  misterj

                  shibble, without the information requested by arcticwind no guesses are possible.  I hope you are not expecting to get video from the connector on the MB, because your 2700X does not have an Integrated Graphic Adapter.  Enjoy, John.

                  • Re: Ryzen 7 2700x no display on boot
                    arcticwind

                    So, you are using the F23f version of BIOS?

                    Are all BIOS settings set to "Default" or "Auto"?

                    Is the PCIe slot with the GPU in it set to "Enabled"?

                    Does your power supply have enough WATTAGE and AMPS to run your GPU?

                    Are all power connectors plugged into the GPU?

                    Is your monitor plugged into the GPU and not the motherboard?

                    Are all power connectors plugged into the motherboard?

                     

                    Are there any bent pins on the processor?

                    Is there anything that might be shorting out the motherboard?

                    Is your RAM compatible with your motherboard? (is it from the QVL list?)

                     

                    INFORMATION REQUIRED WHEN POSTING A QUESTION 

                      • Re: Ryzen 7 2700x no display on boot
                        shibble

                        Hi, I do not know what version of bios I have, I was told by the supplier they have flashed the latest bios, but I am unable to see as I cannot get any video to the monitor. I have a new 750 watt thermaltake  psu, all power connectors are plugged into the motherboard, monitor is connected to the gpu, I have tried both hdmi and DisplayPort.

                        Ram is compatible as it was bought as a bundle (cpu, ram, motherboard).

                        I cannot see any bent pins on the cpu.

                        I have tried everything that I can think of.

                        I really appreciate your help in trying to solve my problem.

                        Ian

                        Sent from my iPad

                        • Re: Ryzen 7 2700x no display on boot
                          shibble

                          I would just like to add that the message i get from the monitor is, There is no signal coming from the monitor.It sounds to me to be a CPU problem but i bought it as a bundle of ram , CPU , motherboard and it was tested at the company. The company is Overclockers uk who are quite a big company in the UK.Once again I am extremely grateful for all your help.Ian.

                           

                          Sent from my Samsung Galaxy smartphone.

                            • Re: Ryzen 7 2700x no display on boot
                              elstaci

                              Once you are able to boot into Windows, you should update the Motherboard's CHIPSET to the latest: GA-AX370-Gaming K7 (rev. 1.0) | Motherboard - GIGABYTE U.S.A.

                               

                              According to this old thread at ExtremeOverclocking.com : Gigabyte EP45T-EXTREME boot codes - EXTREME Overclocking Forums .

                               

                              The 02 Motherboard error concerns the Dual Bios.

                               

                              Try Resetting the BIOS thru the CMOS CLEAR Switch or shorting bridge pin. You can find out the proper way to reset the BIOS in your particular Gigabyte Motherboard using the CMOS CLEAR feature.

                                • Re: Ryzen 7 2700x no display on boot
                                  shibble

                                  Hi, Thank you for taking the time and trouble to reply, it is very much appreciated.

                                  At the moment I am unable to boot into windows because I get a message on my monitor saying that the monitor is not receiving a signal from the motherboard.

                                  I have tried to clear cmos as you suggested but I still have the same problem

                                  The CPU fan is spinning as is the VGA card fans.

                                  I have tried removing all memory, then just using 1 stick of ram.

                                  Ian

                                    • Re: Ryzen 7 2700x no display on boot
                                      elstaci

                                      What is the GPU Card you have install on your Computer. As mentioned previously, the Ryzen CPU doesn't have integrated Graphics on it. So if you are connecting your Monitor directly on the Motherboard's video outputs (HDMI, DVI, DP, or D-Sub) you will not get any video except the error message you are receiving now.

                                       

                                      This is a picture of your motherboard's outputs. See the Video Outputs. This is not the place to connect your monitor.
                                      Picture0003.jpg

                                       

                                       

                                       

                                      You mentioned that the VGA Fans are working so that means you have a separate GPU card installed. What is the Make & Model of the GPU card you have installed?

                                       

                                      Do you have the Monitor cables connected to the GPU card or to the Motherboard?  How is the monitor connected (HDMI, DP, DVI) or are you using an adapter DVI-HDMI or DP-HDMI etc?

                                       

                                      Before troubleshooting further please post your answers to above questions.

                                       

                                      I am trying to see if it is your CPU or GPU or misconnection that is the reason why you are not getting any video output.

                                        • Re: Ryzen 7 2700x no display on boot
                                          shibble

                                          Hi, I have tried both a Amd radeon 5770 and a NVidia gtx1060 6gb

                                            • Re: Ryzen 7 2700x no display on boot
                                              elstaci

                                              Okay that is clearer now. We can at least eliminate the GPU cards. By the way, I would use the GTX 1060 card while troubleshooting this issue since it is a much newer and better card than the obsolete HD 5770.

                                               

                                              If your Motherboard has the latest BIOS installed, Your Ryzen should be supported and should be able to boot up. Unless you have a wrong RAM Memory installed or misconfigured Memory.

                                               

                                              Are you able to Boot up into BIOS by any chance? or just get a black screen from the moment you power up? No beeping sounds when booting up?  What troubleshooting Motherboard LEDs (CPU/GPU/MEMORY/Etc) are lit beside the Error Code 02?

                                               

                                              If you are able to, try installing another Ryzen CPU on your motherboard or your current CPU on another compatible Motherboard and see if it does the same thing.

                                               

                                              It is either a defective Motherboard or defective CPU or Misconfiguration or some hardware you have installed is not compatible with the Ryzen.

                                               

                                              I would open a AMD EMAIL SUPPORT TICKET and see what they suggest: Email Form .

                                               

                                              Also maybe open a AMD RMA REQUEST online and explain the problem to them and see if they ask you to RMA the CPU from here: AMD Warranty Request Form