1 Reply Latest reply on Jul 22, 2018 6:50 PM by kingfish

    AMD Radeon HD 7450M Drivers doesn't work anymore.

    kocero

      Hey. I have a problem that I tried to solve for 1 week. I have a old laptop that named "HP Pavilion G6 1309et". Problem is, I can't use the GPU driver that works on the past month.

       

      I tried these things:

      - I uninstalled drivers with Display Driver Uninstaller and I installed the latest "Crimson Edition 16.2.1 Beta" driver. That didn't work for me. Games doesn't play on high performance. Normally i get 30 FPS on Payday2 but now i get 20 FPS.

      - I did the same thing again but I installed the "15.7.1" one. Now when I go into a game: game works on the onboard GPU (Intel HD Graphics 3000). It's even worse. Games work on 10 FPS. Even on GTA San Andreas.

      - I tried to uninstall drivers on control panel and device manager. Now on device manager my GPU has a yellow warning sign on it. And it became "Standard VGA Graphics Adapter". I tried to update on device manager. That didn't worked either.

      - I tried to change switchable graphics on BIOS. (Fixed, Dynamic). Didn't worked.

      - I tried to install older drivers on my notebook's website. (Really old. Like 8 years old.)