7 Replies Latest reply on Aug 1, 2018 8:37 PM by mshorter

    Can't install OS

    mshorter

      I recently bought some some new parts to upgrade my computer.  The case, power supply and graphics card are old and proven to work.  The motherboard, CPU and memory are new.  The hard drive is also new, but I've tried with 2 new SSDs as well as booting off a old hard drive with Windows on it with no luck.  So I've narrowed it down to the motherboard, processor or RAM.  I'm able to get in the Bios, and start a Windows install.  I will get a loading files screen followed by the Windows logo and spinning dots.  After about 5 minutes I tend to get a BSOD with a "Driver PNP Watchdog" error.  I've also gotten a "0xc00000e9 An unexpected I/O error has occurred" error as well as errors telling me that it can't find the boot device (I haven't touched the boot device and a restart will fix that).  I've also tried installing Puppy Linux which seemed to freeze after the line ""End Kernel Panic - not syncing: timer doesn't work through Interrupt-remapped IO-APIC".

       

      I tried removing each of the memory sticks as well as swapping their slots and still got the same errors.  I also ran Memtest+86 on each stick for about 12 hours and got through 11 passes on each with no errors making me believe it is not the memory and so either the motherboard or processor.  I have been trying to work with the motherboard manufacture as well.  They suggested downgrading the Bios to see if that would help.  I was able to sucessfully downgrade the Bios, but am still getting the same issues.  I'd also like to note that it does take about 60 seconds to get past the initial Bios screen (the press F2 to enter Bios screen) and even try to boot.  It also takes a while to get into the Bios if I choose to do that.  I've tried this both with a Yumi multiboot flash drive as well as running the official MS Windows install tool to load the drive.  I've also used an SD card in a USB adapter so it shouldn't be the flash drive either.

       

       

      Ryzen 5 1600 - with stock cooler - Amazon.com: AMD Ryzen 5 1600 Processor with Wraith Spire Cooler (YD1600BBAEBOX): Computers & Accessories

      ASRock AB350 Pro 4 (Bios 4.60 to 3.30)- Amazon.com: ASRock AB350 PRO4 ATX Motherboard: Computers & Accessories

      GSKill Ripjaw V Series 2400MHz, 2x8GB sticks - G.SKILL 16GB (2 x 8GB) Ripjaws V Series DDR4 PC4-19200 2400MHz Desktop Memory Model F4-2400C15D-16GVS at Amazon.com

      850W Power supply - Amazon.com: Seasonic FOCUS Plus 850 Platinum SSR-850PX 850W 80+ Platinum ATX12V & EPS12V Full Modular 120mm FDB Fan 10 Y…

      Geforce GTX 960 Graphics Card - Amazon.com: Asus STRIX GeForce GTX 960 Overclocked 4 GB DDR5 128-bit DisplayPort HDMI 2.0 DVI-I Graphics Card: Computers…

      WD SSD - Amazon.com: WD Blue 3D NAND 500GB PC SSD - SATA III 6 Gb/s 2.5"/7mm Solid State Drive - WDS500G2B0A: Computers & Accesso…

       

      Processor/Mobo/Memory were selected based on a Newegg bundle

       

      Thanks for any help,

      Michelle

        • Re: Can't install OS
          misterj

          mshorter, Google says your stop error is most likely a disk error.  What OS are you trying to install and where - assume your SSD?  You did not mention any hard drives, but assuming you have some, please try installing Windows on one.  I suggest DLing a copy of W10 from MS using the Media Creation Tool.  Write the install files to a USB stick  and boot that via F11.  Please do this even if you do not want W10.  Good luck and enjoy, John.

            • Re: Can't install OS
              mshorter

              That is basically what I've been doing.  That error message is from trying to install Windows from a USB drive (usually from a multiboot drive, but sometimes from a drive created from MS's Media Creation Tool).  I have tried it with 2 different SSD (on more than one Sata port) with no luck.  Your post did give me an idea to try it not on a Sata port, I removed the drive and hooked it up using an adapter to a USB port and got the same error.  But given that Windows install never gets far enough to ask where I'm installing the OS (or anything else) that's not surprising.

                • Re: Can't install OS
                  misterj

                  Thanks, mshorter.  I did not absorb all your first post completely.  Please do not attempt to use a cloned OS or a boot drive from another system - nothing but headaches.  Please tell me what OS you are trying to install.  Do you not have any hard drives?  I would suggest you go back to the latest BIOS.  Please boot into the BIOS, do a Load UEFI Defaults then Save and Reboot.  Enter BIOS again and use Instant Flash to updated your BIOS from a USB stick.  Reboot into BIOS and do a Load UEFI Defaults then Save and Reboot.  This time use F11 to boot your Windows Media Creation Tool W10 USB stick and try to install.  Is your to-be boot disk style MBR or GPT?  Please stick with W10 till it works.  Enjoy, John.

                    • Re: Can't install OS
                      mshorter

                      I can try that, but since I started with Windows 10 (64-bit) install using the Media Creation tool and the mobo's updated Bios and it didn't work (which is why I contacted the mobo manufacture in the first place) I don't expect anything. 

                       

                      As mentioned above I have tried this on 2 different brand new solid state hard drives .  I've mostly been using the WD one linked in the original post, but did try the other one to verify it wasn't the hard drive.  Similarly the attempt to boot from another drive with an old version of Windows was to see if it was a hard drive or install only issue.

                       

                      As for MBR or GPT I don't know.  I'm assuming the drive is MBR, it was a standard USB drive until I ran YUMI or the Media Create Tool which could have overwritten it.  Again, most installs were done with the drive created by YUMI as a multiboot since it allowed me to run memtest, attempt linux installs, etc.  But I got the same errors using is to install Windows 10 as I did running the drive created by the Media Creation Tool.

                • Re: Can't install OS
                  elstaci

                  Your Kingston RAM MEMORY for Ryzen IS NOT LISTED at ASRock Motherboard QVL list for Ryzen CPU: ASRock > AB350 Pro4

                  DDR4G.Skill240024008GBF4-2400C16D-16GFXSS2
                  DDR4G.Skill240024008GBF4-2400C15D-16GFTSS2
                  DDR4G.Skill240024008GBF4-2400C15D-16GFXSS2
                  DDR4G.Skill240024008GBF4-2400C16D-16GFXRSS2
                  DDR4G.Skill240024008GBF4-2400C16D-16GFTSS2
                  DDR4G.Skill240024008GBF4-2400C15D-16GBTZRSS2
                  DDR4G.Skill240024008GBF4-2400C15D-16GFTSS2
                  DDR4G.Skill240024008GBF4-2400C15D-16GFXRSS2
                  DDR4G.Skill240024008GBF4-2400C16D-16GFXRSS2

                   

                  The Kingston RAM MEMORY MODULE that you linked to has the following Module Number : F4-2400C15D-16GVS

                   

                  Ryzen CPU/APU seems to be sensitive to the type of RAM MEMORY Modules installed.

                   

                  You also have a newer BIOS Update: ASRock > AB350 Pro4

                   

                  4.902018/7/127.28MBInstant FlashHow to Update1.Update PinnaclePI-AM4_1.0.0.2 Patch A
                  2.Improve PCIe detection with Raven Ridge CPU
                  3.Keep the XMP setting after system restoring from G3 state.
                  * If the current BIOS version is older than P3.40, please update BIOS to P3.40(Bridge BIOS) before updating this version.
                  Global China

                   

                  Make sure your BIOS is correctly configured to run your SSD: http://asrock.pc.cdn.bitgravity.com/Manual/AB350%20Pro4.pdf

                   

                  Picture0001.jpg

                  Picture0002.jpg

                  Picture0003.jpg

                  In BIOS does your SSD show up as being detected and installed?  Is your SSD Formatted and Partitioned where BIOS is able to detect it?

                   

                  Is the SSD the Main Hard Drive on your computer or do you have other SSDs or Hard Drives installed?

                   

                  Maybe if you installed your SSD in another computer and install Windows 10 on there then install on your computer.

                   

                  This is the latest YUMI Multiboot USB program: YUMI - Multiboot USB Creator | USB Pen Drive Linux .

                  • Re: Can't install OS
                    mshorter

                    After talking with ASRock they recommended a replacement motherboard.  The replacement worked just fine and I haven't had any issues with it.  Thanks everyone for your help.