3 Replies Latest reply on Jul 20, 2018 2:22 AM by pokester

    Destiny 2 RX580 Crossfire Issues

    psnieds25

      So I am having some issues trying to run Destiny 2 with RX580 8gb in crossfire.  I get about half the framerate as when I disable crossfire.  I've scoured the internet and nothing seems to be working.  I've disabled ULPS and tried all the crossfire profiles.  Currently, I run at 1080p with all the settings maxed and get a steady 60fps (capped at 60 because my monitor is 60Hz). When I load in with crossfire enabled, I get 35ish with all the settings the same.  I have a 4K monitor and want to get a steady 60fps at a higher resolution.  Any idea on what to do?

       

      The only thing I haven't tried yet (which I don't think is an issue, but correct me if it may be), is that I use one power cable to power both GPUs.  It's an 8pin from the PSU that goes to an 8pin and 6+2.  It's a cable that came with the PSU, not a splitter or anything extra.  Both GPUs are recognized by my system and both of them spin the fans when under load.

       

      System Specs:

      2x Sapphire Pulse RX580 8gb

      ASUS Z370-A motherboard (2x PCIE x16 running at x8 with 2 GPUs)

      Corsair 1200W Platinum PSU

      Intel i7 8700K CPU

      16GB DDR4 RAM

       

      Any help/ideas would be greatly appreciated.  Thanks!

        • Re: Destiny 2 RX580 Crossfire Issues
          pokester

          I don't have this game only know what I just read elsewhere specifically about D2. You say cross fire? Are you running DX 11 or 12? If you are running DX 12 then crossfire needs to be off because that is multi gpu as crossfire and sli are discontinued in DX 12 and mulit gpu is controlled by the game engine not driver. If you have crossfire enabled and run a DX 12 game that could be causing performance issues. If you are running Crossfire you must run DX 11. I see reports that crossfire does benefit in DX 11 so from there I can't speculate the issue of performance drop if you have it enable correctly beyond making sure you don't have VSYNC enabled anywhere either.