AnsweredAssumed Answered

[RX 480] Frequent freezing/screen going black after driver update

Question asked by peermeneer93 on Jul 12, 2018
Latest reply on Jul 12, 2018 by sebastian_alvarado

Hi everyone,

 

I have an annoying problem that i just can't seem to fix for some reason, and it happens when playing certain games. If you guys could possibly help me out, id appreciate it a lot.

 

System info

System: Windows 10 64-Bit, RX 480 Graphics, current driver version is 18.5.1.

16GB Ram, Ryzen i5 processor, AOC G2460VQ6 Monitor

 

Please excuse me if some details are missing, i am not that knowledgeable when it comes to this subject. If there is any additional information required please let me know and i'll happily find it out and post it.

 

The problem

I play mostly Rocket League on my PC, and casually other steam games such as Team Fortress / Planet Coaster.

I've ran these games for a long time with my RX 480 Graphics card without any issues whatsoever.

Then, one day, i noticed that Rocket League started lagging more, and the game started to run slower and slower and even occasionally freezing.

It then became so bad that it felt like i was playing at 800 ping. I then decided to do a driver update.

This is where the issues that i am currently experiencing began.

These happen only within games, and they also only happen when certain buttons are pressed.

I use a PS4 Controller for Rocket League and keyboard for all other games, but this does not seem to matter as the issue occurs on both.

Also, as for Rocket League, the issue does not seem to occur within matches. It affects mostly buttons that are linked to menu's and navigation such as Leave match, Find match, Options, etc.

 

The screen freezes a lot, goes black, occassionally even goes green, and makes a weird noise.

A video can be worth more than a thousand words, so i made a video of the problem:

https://youtu.be/1-5NKaAm6Wo

 

Things i tried, but didn't work.

- Tried installing 3 different driver versions

- Re-installing Rocket League completely

- Set windows system restore to an earlier point in time before the issues (Worked temporarily, until RL started runny slowly again)

- Verified integrity of game cache on steam

- Set all the graphics card frequencies to all have the same value

 

If someone  has experienced similar issues or knows a possible fix for this, i'll gladly hear it and i will be highly thankful to you

Outcomes