10 Replies Latest reply on Jun 28, 2018 2:34 PM by orkprof

    AMD not detected by game

    orkprof

      A game I'm trying to play won't detect the R8 profile and thus won't list it among the available options (in-game menu).

      I first opened the AMD Radeon control panel, went to System > Switchable graphics and set the game in question on "high performance". The game still wouldn't detect the (then) R7 graphics, only the R5. I looked the issue up and saw many people suggesting to update the drivers first, so I did just that: R5 was already ok, R7 was automatically upgraded to R8.
      Still, the game won't detect it. On top of that, after such upgrade the "Switchable graphisc" tab has disappeared from the AMD Radeon control panel.

      Operating System:
      Windows 10 Home 64-bit

      CPU: AMD A8-9600

      Bristol Ridge 28nm Technology

      RAM: 12,0GB Dual-Channel Unknown @ 931MHz (13-13-13-31)

      Motherboard: HP 81FA (Socket FP4)

      Graphics:
           Generic PnP Monitor (1366x768@60Hz)

           512MB ATI AMD Radeon R5 Graphics (HP)

           2048MB ATI AMD Radeon R8 M445DX (HP) ( <<< this used to be an R7, until I downloaded the upgraded driver the other day)

           CrossFire Disabled ( <<< could this be the problem? Should it be enabled?)

      Optical Drives: hp DVDRW GUD1N

       

      Thanks in advance for your time and availability.
      Franco

        • Re: AMD not detected by game
          kingfish

          This is not the same specs you posted on your other thread. Please correct one or the other.

          Dell Inspiron 15 5565 Specs - CNET

            • Re: AMD not detected by game
              orkprof

              I apologize for the confusion, though the only difference I seem to notice is that the OP of the other thread had a Dell, while I'm using an HP.
              The specs I posted here are the correct ones, in any case. I'll refrain from posting under the other thread, to avoid further misunderstanding.

               

              As for the driver (ref. your reply in the other thread), it was updated automatically from Windows device manager... is it really possible to download the wrong driver that way?

               

              In addition, I just noticed that while CrossFire is indicated as "disabled" by Speccy, it seems to be fully enabled according to the AMD Radeon control panel (Games > Global settings).

                • Re: AMD not detected by game
                  kingfish

                  To avoid confusion > INFORMATION REQUIRED WHEN POSTING A QUESTION

                  You said the only difference was the manufacturer...well he has a FX 9800P APU

                    • Re: AMD not detected by game
                      orkprof

                      Right, I never actually said I had that, just the same issue, but I can see how I caused the misunderstanding by posting there, so again, I apologize for the confusion. I am sorry.

                      I am double-checking the info in my OP here using the last link you provided: here's the missing info, along with further details I found, in case they may be needed:
                      - Laptop computer;
                      - processor: "AMD A10-9600P Radeon R5, 10 - COMPUTE CORES 4C+6G, 2.40 GHz"
                      - power supply: (not sure about this, I'll copy what I can read from the cable) "LS-18 Longwell 2,5A 250V" (no sign of wattage)

                      - storage: 931GB Hitachi HGST HTS541010A9E680 (SATA)

                      - audio: Realtek High Definition Audio


                      I apologize if anything important is still missing or if I reported anything incorrectly, this really isn't my field. I'm trying my best.

                       

                      I ran Speccy again and it still says CrossFire is disabled for both R5 and R8, but in the AMD Radeon control panel it appears to be enabled....

                        • Re: AMD not detected by game
                          kingfish

                          First do a clean install of the AMD driver...special attention to *delete previous drivers C:/AMD *prevent Microsoft installing drivers automatically. In fact, disable the internet until you have finished installing everything.

                          Screenshot_2.png

                          APU

                            • Re: AMD not detected by game
                              kingfish

                              Also, what is the exact laptop model?

                              Since you had problems opening a link...google  Radeon™ Software Help Center

                              Explanations there on crossfire/switchable graphics.

                                • Re: AMD not detected by game
                                  orkprof

                                  Hi; I've followed all steps, uninstalled anything AMD-related then reinstalled the drivers.

                                  R8 M445DX reverted to R7 M340, but it's still not detected by games.


                                  I googled Radeon™ Software Help Center, followed the instructions to create a profile for this specific game in the AMD Radeon Control Panel, and selected the pre-defined profile for it from the list under AMD CrossFire mode. I also went to System > Commutable graphic cards and made sure the game is set to "high performance".

                                  R5 is still the only one detected by the game.

                                   

                                  Laptop model: on its back it says model: 15-ba011nl, is that right? Or shall I look for a different code?

                                • Re: AMD not detected by game
                                  orkprof

                                  So, I've done the Clean Install. :-)
                                  What now?

                                      • Re: AMD not detected by game
                                        orkprof

                                        Thank you kingfish; unfortunately, I was already aware of this, and I've already tried it multiple times. While it did help improving the performance of some games in the past, it does not bring individual games to detect R7. Games set on "high performance" do appear to be associated to R7 according to the AMD Radeon control panel, but in reality they just aren't.

                                        Middle Earth: Shadow of War
                                        , for instance, or Path of Exile, explicitly offer the chance to select a video card, but they only list R5 as the sole option. Shadow of War clearly shows to be using R5, as it states the video card has only 512MB of available memory (which is R5's; R7 has 2000+), and the game needs 1300MB.

                                         

                                        Similarly, while both R5 and R7 are listed as available, installed video cards in Windows Device Manager, R5 is the sole option when it comes to Windows Screen options. I simply cannot associate R7 to my laptop monitor, or any other monitor I may connect to my laptop.

                                         

                                        Another strange thing is that Speccy keeps saying that CrossFire is currently disabled, whereas the related option inside the AMD Radeon control panel appears to be activated.

                          • Re: AMD not detected by game
                            orkprof

                            In case it may help: since the laptop monitor appears to be connected with the R5 only, and this doesn't seem to be changeable anywhere, I tried plugging in a second monitor using a HDMI cable: even this is automatically connected to the R5, with no available option (that I can see) to switch to R7.