1 Reply Latest reply on Jun 23, 2018 2:27 AM by goodplay

    Why is my new RX 580 not having any display before the drivers load?

    pjcwilliamson

      Computer Type: Custom build PC

      GPU: MSI RX 580 8GB V1 in PCI-E x16, factory; MSI RX 570 4GB Armor OC in PCI-E x4, factory. Crossfire currently off. 25GB Virtual Memory.

      CPU: Ryzen 1700, no OC

      Motherboard: ASRock X370 Pro4

      RAM: 8GB

      PSU: PowerSpec 650 Watt 80 Plus Bronze ATX Power Supply

      Operating System & Version: Win 10

      GPU Drivers: Currently Radeon 18.2.3 (but similar results with fully updated radeon drivers)

      Chipset Drivers: 18.10? This led me down a rabbit hole. I don't know how to determine this, but I ran the installer for the 18.10 chipset drivers from AMD. Lots of unclear things (like, what is the "Local Driver" in the AMD software installer?)

      Background Applications: None

      Description of Original Problem:

      I've been using on a single GPU - the 570.

      I just added the 580.

      When using the RX 570, I would still get display signal before radeon drivers had loaded. This is important for seeing the motherboard splashscreen, for going to BIOS, and for doing clean installs of the drivers.

      Now that I have the new RX 580 in the main PCI-E slot, nothing displays before the radeon drivers have loaded. This means I cannot get to BIOS (or at least I cannot see it!), and if I uninstall drivers for a clean install, then I can't even use my computer to install the drivers (so far I've navigated this by unplugging the 580 so that it switches to the 570)

      Troubleshooting: Installed new chipsets, take the 580 out and put it back in, update radeon drivers (I've tried both 18.5.1 and 18.6.1 - same result)