0 Replies Latest reply on Jun 14, 2018 8:31 AM by ondol

    OpenCL applications crashing

    ondol

      Hello,

      I am using Corel Aftershot as my photo editing software. Until recently, everything was running fine, but I decided to upgrade my system which was to that point using an integrated Intel GPU in the I3-6100 processor. As the Aftershot program can utilize OpenCL, I decided to buy a better GPU and purchased a MSI RX 560 AERO ITX 4G OC.

      After hardware installation, the OS - Windows 10 Pro 64bit - hanged (only the windows logo was onscreen for an hour).

      I power cycled the system, this time booted holding the shift key - and after System restore did not find any problems, the system booted just fine.

      Then I installed most recent drivers from AMD - 18.6.1, rebooted again and finaly tried the one program for which I purchased the upgrade - Aftershot.

      Unfortunately, it crashed immediately and keeps crashing since then - only the splashscreen is shown, and then it disappears without any message (confirmed via taskmanager).

      So I reinstalled and updated it - no luck, still keeps crashing.

      So I decided to try another program utilizing the OpenCL capabilities of my new GPU - as I do not have any other, I searched and find a few OpenCL benchmars - for example CompuBench 2.0 (https://compubench.com/result.jsp) but also a few more - and none of them worked! Most did not start at all, some like CompuBench at least displayed a splashscreen before disapearing without a trace.

      As all the other, regular applications not utilizing OpenCL work just fine - I assume there is a problem in my installation with the OpenCL driver.

      Can anyone suggest any solution?

      Thank you!