colesdav

ROCm installation failure with amdgpu-pro 18.10 driver installed.

Discussion created by colesdav on Jun 7, 2018
Latest reply on Jun 14, 2018 by colesdav

System Information.


CPU= i74790K
Motherboard = ASUS Z97 Deluxe NFC & Wireless.

GPU 1 = R9 Fury X

GPU 2 = R9 Nano.

GPU 3 = R9 Nano.

OS = Ubuntu 16.04 LTS

 

Downloaded and installed:

Radeon™ Software for Linux 18.10 Release Notes


I used the following installation command.
amdgpu-pro-install -y -opencl=legacy

 

Question 1. Is this the correct command to use to install OpenCL  for ROCm with this driver for R9 FuryX Nano Cards?
or should I be using amdgpu-pro-install -y -opencl=rocm?

 

I then went here: ROCm Install

followed the installation instructions to install ROCm and I hit this error during installation:

 

dpkg: error processing archive /var/cache/apt/archives/rock-dkms_1.8-151_all.deb (--unpack):

trying to overwrite '/usr/share/dkms/modules_to_force_install/amdgpu', which is also in package amdgpu-dkms 18.10-572953

dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

 

Question 2. Does this indicate that the ROCm installation does not work with the amdgpu-pro 18.10 driver at all?
Question 3. Has anyone tested this with R9 FuryX or Nano Cards?

 

Thanks.

Outcomes