1 Reply Latest reply on Jun 4, 2018 4:55 AM by ender_doc

    Radeon Settings wont open after the latest update 1.8.5

    ender_doc

      AMD Radeon 530 2Gbs

      Laptop- Lenovo Model Ideapad 320 15ast

      Windows 10 64-bit

      AMD Adrenalin Software version 18.2.1

      Generic PnP Monitor 1366x768 (32bit) (60Hz)

      Motherboard: ? Bios Revision: 5PCN18WW    (Not exactly sure if its this)

      AMD A6-9220 Radeon R4, 5 Compute Cores 2C + 3G (2CPUs), 2.5Ghz - 2.9Ghz

      Ram: 8Gbs

      I was running AMD adrenalin version 1.8.1 if i remember correctly, an update for version 1.8.5 but i didnt download it right away about 2 weeks pass and today since i wasnt having internet issues i tried updating since there was no reason not to even if in the patch notes there wasnt any obvious benefit, it starts updating after a while screen turn black (didnt turn off just black) and blinked off for a just a moment then while the music that i was listenning to starts reppeating itself. At most 1 minute passed but i'd say it was about 2 seconds and windows rebooted which i thought was a bit strange. I logged back in and noticed 2 things as i tried to open Radeon Setting, One the icon was BLUE and it say "Radeon Pro and AMD FirePro Settings". I clicked to open and error popped up, "RadeonSettings.exe - Invalid Image" , "C:\WINDOWS\SYSTEM32\atiadlxx.dll could not be executed. Try reinstalling program or using original instalations. Error 0xc000012f." (It was written in my mother language but translated its basicly what is was saying)

      The laptop came with a AMD Radeon 530 but after downloading the drivers (in February) the card had its name changed to R7 M565X or R7 M545X (cant quite remember), i didnt think much of it since the performance got better and the UI for Radeon Settings was better and had more options. But after this incident (refered above) the card name switched back to AMD Radeon 530 (Im guessing the drivers switched to the old ones) and before coming here i tried using the adrenalin 18.2.1 setup but got the same error box, tried uninstalling from windows through "Add or Remove Program" and got the same error box, i think i can still play games but the performance of the graphics card already came a little toned down (Max Core Clock was 891Mhz instead of the 1020Mhz it should have, probably to keep it from themal throttleing) and then the optimal drivers for gaming got switched back to the ones i had worse performance.

      I'll be checking this post every 10 minutes for the first 1HR after posting then I'll be checking it for every 30mins for 2HRs then after that I'll be checking every 3-5HRs for the rest of the day.

      (My mother tongue is portuguese if you need to translate what is in the pictures)

        • Re: Radeon Settings wont open after the latest update 1.8.5
          ender_doc

          While waiting for someone to respond i decided to understand why i was having this issue and if anyone else had this issue, this may have happened because of my specific machine or maybe the update had an 1 in 1 million error to happen, whatever the cause may be i fixed my issue now.

          If anyone had the same problem, what i did was download the AMD clean uninstall utility tool ( you can search for it on google first site pops up will be amd click it) executed it, removed all drivers (be careful when you do this you may lose your display output, my last laptop had the same problem, so i dont know if newer ones can just use the raw power of the cpu to support display while no drivers are installed for graphics(both my graphical devices had their drivers removed) or if its somehow still using the graphics card), after that execute the software needed for you graphics card, in my cause that was Adrenalin.

          Once done i reccomend you do not try to do the same update as you may have the same problem again, remain with the version of the software you have now and wait a while (about a week) to make sure the problem wasnt on your end.