3 Replies Latest reply on Jul 17, 2018 6:07 PM by dusanryzen

    Ryzen 3 2200G Problems

    mr.nobody999

      I have recently bought a Ryzen 3 2200G APU. I get very poor FPS at few games which I should've run at 30+ FPS at medium settings. I tested this on GTA V. It barely reaches 35 FPS at low settings. I saw many people reaching 40+ FPS on Far Cry 5 at low settings but I barely reach 25 FPS at low settings (20 FPS at average). I've also installed Adrenalin 18.3.4 driver which has Far Cry 5 support but no luck. My GPU Core Clock speed shows only 400 MHz instead of 1100MHz at stock settings. (Image down below.) Any ideas how to fix that?

       

      My specs :
      AMD Ryzen 3 2200G

      ASRock AB350M-HDV

      GeIL EVO POTENZA 8GB DDR4 3200MHz Single Channel Ram

       

      Untitled.png

        • Re: Ryzen 3 2200G Problems
          zachmdful

          The APU needs dual channel ram to run at the speeds you're seeing online.

          1 of 1 people found this helpful
            • Re: Ryzen 3 2200G Problems
              mr.nobody999

              I bought another one after few days I posted this one and it worked! Thanks though. It may help others.

              • Re: Ryzen 3 2200G Problems
                dusanryzen

                I have the following problem with almost the same hardware:

                1) Ryzen 3 2200G, 2) ASRock AB350M pro4 motherboard.

                Win 10 Pro up-to-date, Latest UEFI (BIOS) updated.

                 

                Drivers for AMD Radeon Vega 8 won't install at all.

                 

                Yellow triangle when I check Device Manager: "Display Adapters"...

                Device status:

                This device cannot find enough free resources that it can use. (Code 12)

                If you want to use this device, you will need to disable one of the other devices on this system.

                 

                I've tried uninstalling VGA drivers, then I get plain "microsoft generic driver"

                Then I install AMD drivers back, everything seems fine, restart... and I get the same yellow triangle again.

                 

                Latest Driver pack used: Win10-64Bit-Radeon-Software-Adrenalin-Edition-18.7.1-July12

                I tried to install unpacked VGA driver from within Device Manager, works well, restart... yellow again