AnsweredAssumed Answered

System crashing on video tasks - Ryzen 2200G

Question asked by a13antichrist on May 25, 2018
Latest reply on Jun 4, 2018 by a13antichrist

Where could be the problem?

 

System is:

- Ryzen 2200G @stock & Noctua L9

- ASRock Fatal1ty AB350 ITX; BIOS L4.51D

- 8Gb Corsair Vengeance LPX 3200Mhz@3200Mgz

- Samsung 960 Evo

- PicoPSU but have tried full ATX also

- Windows 10 b1803

- Andrenaline 18.5 (at present), display driver 24.20.11016.4

- no O/C anywhere yet

- system & CPU temps never cross 40°C

- Monitor is a 4K+HDR television.

 

I've recently built this machine (brand new) but am having constant crashes anytime I try to do anything graphics-related. I get a number of different blue-screen reports:

 

DRIVER_IRQL_NOT_LESS_OR_EQUAL

SYSTEM_SERVICE_EXCEPTION

KERNEL_something-something-I-forget-exactly

and there was another one which I forget also.

 

And depending on the case I have had two registers called out also:

atikmdag.sys

dxgmm2.sys

 

So it -seems- to point to something Radeon-driver-related.

I am currently using BIOS L4.51D; I had the 4.60 on before but changed it as I thought I was getting system shutdowns randomly; appears it's just the OS shutting off the CPU fan when sleeping - seemed odd to me but ok.

 

I was using a 17.x Radeon driver, upgraded to the 18.5.1 but that hasn't helped.

 

 

- Playing Youtube in 4K it will sometimes last a fair while, an hour or so or sometimes only a few minutes; then the Chrome tab may crash or the video might start going blocky or distorted, sometimes one then the other.

- Playing HEVC 265 video in VLC crashes the computer within a few minutes. Playing on MPC-HC lasted a bit longer, got up to 30mins or so.

 

I have tried with multiple memory sticks (have some 2666 modules here, also tried running the 3200 at only 2133) and multiple PSUs. No tangible differences in behaviour there.

I don't have anything happening on this machine at present; it's to be the HTPC so only a couple of media players installed, and nothing heavy yet.

Another thing - if I enable the HDR + WCG setting in windows, the CPU grinds to almost a halt when playing a 4K HDR video in Youtube. Weird..

 

Some 'progress' I have made:

I removed all AMD drivers using the AMD Cleanup Utility. Then I re-installed the graphics drivers -only- and manually using Device Manager and not the packaged installation. Full disclosure, the driver package I used for this was the amd-chipset-drivers18.10.0418 which I guess I downloaded in April; Radeon driver version actually lists the same as when installed by the new Adrenaline package release yesterday (24.20.11016.4) so that's a bit odd. Well it also says 'Driver date 16/05/2018 so I'm not entirely sure how that happened But in any case the install was done manually through DM and not the package installer.

 

With this driver installed and none of the other AMD bits (other than Ryzen Master) I am able to watch any 4K Youtube or HEVC media without suffering the crashes - EXCEPT when I turn the HDR + WCG mode on. With that mode enabled I see the same crashes as before.

 

Any ideas? Bad CPU/board/driver install?

I'm going to try another full removal of the drivers, and run the packager from scratch in the meantime.

Outcomes