1 Reply Latest reply on Jul 17, 2018 12:33 AM by dusanryzen

    Ryzen 3 2200G Windows 10 drivers will not install

    ajrocko

      My desktop setup:

      CPU: Ryzen 3 2200G

      Motherboard: BIOSTAR X370GTN, BIOS version X37AK417.BSS (2018-04-17)

      Ram: TridentZ Series 16GB DDR4-3200 Dual Channel Ram, (2x 8GB)

      HD: 240GB SSD Drive

      PSU: EVGA 450W 80+ Bronze Power Supply

      OS: Windows 10 64 bit (Build 1709)

       

      New build, Windows 10 installs fine, biostar chip, network and audio drivers install fine.

      But any AMD GPU driver install fails.

      Both of the below have been tried:

      Radeon Software Adrenalin Edition Q2 2018 Release Notes

      Radeon Software for Ryzen™ Desktop Processors with Radeon™ Vega Graphics Release Notes

       

      Install gets half way, and then crashes, you see rainbow colors, general system instability, and then black screen.  Re-boot does not solve issue.  Drivers either need to be uninstalled or system needs fresh Windows 10 reinstall.

       

      Is this a known issue?  Any other drivers available that work with this setup?

        • Re: Ryzen 3 2200G Windows 10 drivers will not install
          dusanryzen

          More or less the same problem except I don't experience any crashes while installing drivers. I just get yellow triangle and the absence of OpenGL functionality.

          I think the only relevant info on hardware is: 1) Ryzen 3 2200G, 2) ASRock AB350M pro4 motherboard. I use Win 10 Pro.

          Latest UEFI (BIOS) updated.

          I've tried several drivers packs:

          AMD: rv-win10-64bit-whql-radeon-software-17.40.3701-feb12

          AMD: radeon-software-adrenalin-18.6.1-minimalsetup-180613_web

          AMD: win10-64bit-radeon-software-adrenalin-edition-18.5.1-may23

          ASRock (MB manufacturer) drivers pack: Allin1(v17.40.3301-WHQL)

           

          I've tried uninstalling VGA drivers, then I get plain "microsoft generic driver"

          Then I install AMD drivers back and I get the same yellow triangle when I check Device Manager: "Display Adapters"...

          Device status:

          This device cannot find enough free resources that it can use. (Code 12)

          If you want to use this device, you will need to disable one of the other devices on this system.