AnsweredAssumed Answered

2600X defective PCIE lanes?

Question asked by siz on May 22, 2018
Latest reply on Jun 1, 2018 by siz

Hello,

 

I have an extremely frustrating problem. When using PCI-E 16x Gen 3 for my Nvidia Geforce 1060 I experience stutters/dpc latency all the time in Windows, not to mention in games (dxgkernl.sys, ntskrnl.exe, nvlddmkm.sys). Forcing PCIe x16 Gen 1, it works fine

 

Here is a video demonstrating it: PCIe 3.0 - det hakker med tydelig latency - YouTube. With PCIe Gen 1: PCIe 1.0 - Det kører som det skal - YouTube

 

First I thought it was the motherboard (ASRock Fatal1ty AB350M Gaming), so bought a new Asus ROG Strix X470 F Gaming, but have the exact same problem. Then I tried a Radeon HD4890 and R9 380 without stutters, so naturally the graphics card should be the culprit!

 

However, the graphics card works fine without stutters in my old Intel i5 i2500k, Asrock z77 itx system (PCIe Gen 2) and my brothers i7 4770k, Gigabyte Z87X-UD3H (PCIe Gen 3)! The systems are both running Windows 7 64 bit. To be sure, I installed Windows 7 64 bit today, but I have the same issues on Windows 7

 

System:

  • AMD Ryzen R5 2600X
  • Asus ROG Strix X470F Gaming
  • G.SKill Ripjaws V F4-3200C14D-16GVK
  • Palit Gefore GTX 1060 DUAL 6GB
  • Crucial M4 128 GB SATA SSD
  • Corsair RM550 Power supply

 

I have tried disabling all power management settings in bios and windows, tried different bioses, set powers to max, installed 5-6 different Nvidia drivers, tried the 2 latest AMD chipsets drivers, disabled audio/lan in bios, reverted windows 10 back to 1709, installed windows 7. Everything is running at stock, no OC on CPU or GPU. The RAM is running at 3200 MHz, same issues occur with 2133 MHz.

 

TL;DR

Expericing dpc latency, according to latencymon -> Nvidia drivers. Tried swapping MB = still problems, tried different drivers for gfx, chipsets etc., and 2 different windows = still problems, tried 2 AMD gfx cards in my system = no problems, tried my nvidia gfx in 2 other systems = no problems.

 

I seriously do not know what to do next. Changing the PCIe BUS speed to Gen 1 works (using regedit for ASUS, doesn't have BIOS Setting in contrast to Asrock).

The only reason I am suspecting the 2600X is due to the PCIe lanes going through the CPU..

Outcomes