9 Replies Latest reply on May 23, 2018 6:28 AM by strider_sp

    I can't update to 18.2.1 nor 18.4.1

    strider_sp

      Problem: can't update to 18.4.1 nor 18.2.1

       

      Specs: Phenom 955 | R9 380 4gb (powercolor pcs+) | 2x4GB ram | M4A77T USB3

       

      Software: windows 2008 R2 | adrenalin 17.12.1

       

      I usually have no problems installing new drivers, and since my R9 380 doesn't see much improvement between versions, i'm installing only major releases since omega. Crimson, Relive and Adrenaline went smooth. I'm using this OS since years ago, two GPU and two HDD, and the same installation is rock solid. I'm using Windows server 2008 R2, but drivers for 7 works perfectly, it is exactly the same OS under the hood.

      The drivers install perfectly, only few of them back in catalyst era required fiddling the msi files; for sometime this didn't worked anymore, but soon AMD supported this OS again (THANK LISA! AND THANK someone who maybe had read my message about it some years ago in this same community!, It could had been a coincidence, or maybe not), and without any tweaking required, like a charm since then.

       

      But I bought neptunia in this weekend promo, and it requires 18.2.1 or newer driver to fix severe graphical glitches.

       

      I uninstalled the "current" 17.12.1 and tried the new installers on a real clean install, them both showed "unknown amd hardware".

       

      [Strange. I know my gpu came faulty from factory, I bought it new and only could make it reach idle clock with a regedit tweak, (tks powercolor); I think this isn't relevant, since all drivers until first adrenalin installed correctly. Would it somehow not read which hardware is installed? If so, how the previous 17.12.1 and others could do so?]

       

      Running the installers with 17.12.1 already installed starts ok, but the installer hangs and stay there. I can even kill the process and reboot, not a single change made in the system.

      I tried even the radeon pro driver 18Q2, it stops and hangs in the same point.

       

      Anything I can do? Please, I don't want to reinstall my system, who knows which strange updates will be forced in my system when I update it... I know AMD software is rock stable and

        • Re: I can't update to 18.2.1 nor 18.4.1
          kingfish

          Sounds like a OS in need of updates.

          ** Windows 7 and Windows 8.1 must be fully updated before attempting to install any AMD driver. All 'critical', 'recommended', and 'optional' (no language packs,etc) updates as well as any Service Packs (SP) must be installed before any attempt to install graphics drivers. If you do not get this message .... keep installing until you do:

          Screenshot_31.png

           

          WU must be set to deliver 'optional' updates:

          Screenshot_2 (5).png

          • Re: I can't update to 18.2.1 nor 18.4.1
            amdmatt

            We don't have any compatible display drivers for the R9 380 for Windows Server 2008, so this is why you are unable to install them. I'm not sure how you managed to get earlier drivers to work with that OS, so i would suggest either rolling back your driver or using a supported OS as mentioned on the release notes.

             

            Compatible Operating Systems
            Radeon Software Adrenalin Edition 18.4.1 is designed to support the following Microsoft® Windows® platforms. Operating System support may vary depending on your specific AMD Radeon product.

              • Windows® 10 (32 & 64-bit version)
              • Windows 7 (32 & 64-bit version with SP1 or higher)

            Radeon™ Software Adrenalin Edition 18.4.1 Release Notes

            2 of 2 people found this helpful
              • Re: I can't update to 18.2.1 nor 18.4.1
                strider_sp

                About earlier drivers: they installed just fine. And in this very same OS installation, ~7yo.

                A long time ago the catalyst drivers installed ok, but some versions required entering the OS in MSI files using orca; few iterations later it supported this OS natively again without any hassle, even not making it explicit.

                New radeon software were compatible from the start in the same fashion, reason why felt confortable enough to get a new radeon card and a freesync monitor.

                 

                When these '18 new drivers didn't work, I thought that it was a serious bug needing to report. The message "unknown AMD hardware" and its behavior, halting not using processor nor disk and with ram usage slowly decreasing, just reinforced for me that it was a real technical issue with the installer only.

                 

                (While I know that the compatibililty hardware/OS is well documented in AMD site and there's no arguing with that, I'm still hoping that the next version would get it "fixed", but I know that there is no obligation for AMD to do it.)