AnsweredAssumed Answered

Half Memory Usable

Question asked by cohemus on May 18, 2018
Latest reply on May 27, 2019 by cohemus

Hello,

 

I recently upgraded from an old Intel CPU to a new Ryzen 2700 with an ASUS Prime X470-Pro motherboard. After installing the new CPU/Mobo and keeping all the old parts the same, I booted up to find that only half of my 4x4GB kit was usable in Windows (16 GB seen, 8 GB usable). After not having any luck updating the BIOS version, I thought maybe the RAM was bad so bought a newer 2x8GB kit and replaced the old memory with that, but no luck. It also defaults the memory speed to 2100MHz when it's a 3200MHz rated pair, and using the D.O.C.P profile causes the computer to not boot and force me back to the BIOS screen to reset to defaults. Trying to manually tweak it and raise it in small increments, even to 2200 MHz causes the same issue. The memory sticks are listed on the ASUS QVL list.

 

I then got an RMA for the motherboard thinking it was a faulty slot (I made sure the memory was properly seated and in the correct channels per manual), however the replacement (new, not refurbished) did not fix the issue. While waiting for the motherboard to come back, I put back the old Intel combo with the new sticks and got the full 16GB usable. Also setting to the default XMP profile gives me the rated 3200MHz stable.

 

So I then got a replacement for the CPU which just came in today, but again same problem. I'm at a loss right now as the only components that have changed are the Motherboard and CPU, and when returning both of them the same issue persists. It also shows in the BIOS that it recognizes both 8 GB sticks, but only shows 8GB so it's not an OS problem. I reformatted my computer multiple times due to the hardware changes and no luck.  I also read that the cooler can be on too tight, so tried loosening it (aftermarket Noctua) and when that didn't work, applied the stock Spire cooler that came with the CPU.  My old Intel CPU uses more power than the new AMD one, so it does not appear to be power related.  Are there any known issues with this?

 

So to recap:

  • Brand new motherboard and CPU combo only lets me use 8GB of the 16GB installed (tested with two different sets of memory independently)
  • Replacing both with new ones have the same result
  • Using the same components with old Intel Mobo/CPU works fine
  • Issue shows up in both BIOS and OS

 

https://imgur.com/a/TnIOn1g shows what I see in the BIOS and OS (this was taken with the 4x4GB kit but the 2x8GB kit is the same)

Outcomes