4 Replies Latest reply on May 18, 2018 2:25 PM by fallfrominfinity

    Installing SATA RAID driver to existing Windows 10 when not in RAID mode

    fallfrominfinity

      So I recently decided to upgrade to the Threadripper series, getting the 1900 and an Asus Prime X399-A to go with it.

       

      Now on my old motherboard, I had 4 SATA HDDs in RAID 0 and then my SATA SSD as the main OS drive. The old motherboard luckily had only 4 of the SATA ports capable of RAID, the fifth was held out of RAID configuration.

       

      This new motherboard does not appear to have that lucky setting - either all drives are in RAID mode (though not all need to be in a RAID, of course), or all drives are not.

       

      So I tried to boot Windows after configuring the RAID 0 on the other four drives and, lo and behold, Blue screens "Inaccessible Boot device"

       

      Pulled the SSD over to the old motherboard and attempted to enable Safe boot before bringing it over, to see if I could safe boot with RAID mode on - turns out, I could not.

       

      So I switch it back to AHCI and boot Windows, YAY.

       

      I go to download the SATA RAID drivers from the AMD chipset drivers page for the x399, and when I run the installer... it only shows my display drivers (wut?).

       

      Then I download the actual chipset drivers and display drivers and download and install them and reboot, then try the SATA RAID driver installer again, and its a no-go, still only gives me options for display drivers.

       

      So here's what I need - I need to be able to install the SATA RAID driver for my x399 without the system being in RAID mode. Or some workaround that gets that same thing done.

       

      I am desperately trying to avoid reinstalling Windows just to have the RAID driver installed from the start, and I'd rather not do a software RAID (Windows "Striped Volume").

      Do we have any suggestions or things that I can do to get this done?

        • Re: Installing SATA RAID driver to existing Windows 10 when not in RAID mode
          amdmatt

          What system specs were you using previously in which you had a Raid setup?

            • Re: Installing SATA RAID driver to existing Windows 10 when not in RAID mode
              fallfrominfinity

              Motherboard was an ASRock 990FX Extreme 3. The way it worked, while four of the five SATA ports were in RAID mode, the fifth port was still in AHCI mode.

              SanDisk Ultra II 256GB SSD - Windows 10 OS, GPT with UEFI boot

              4x Seagate ST32000646NS 2TB HDDs - RAID 0

               

              I set it up with a similar process of how I'm doing this one. By that, I mean Windows was already installed on the harddrive and the system was in AHCI mode, then I switched it over to RAID mode in BIOS, configured the RAID on my other 4 drives, and booted into Windows. Was able to install RAID driver afterwards, but the RAID volume itself was even available for access before having the driver. (and no, Windows didn't get a chance to download the driver before I checked if it was usable).

               

              But for this one, it doesn't keep any specific ports out of RAID mode, and there's no way to individually set ports in AHCI mode while others are in RAID mode. So although the four 2TB drives will be in the RAID, the SSD with the OS on it will not be - but the board still puts it in RAID mode causing the Windows boot loader to fail to actually load Windows, resulting in a stop.

               

              My issue is, without the board in RAID mode, the SATA RAID driver installer doesn't give the option to install the driver preemptively.

              With the board in RAID mode, I can't boot into Windows.

            • Re: Installing SATA RAID driver to existing Windows 10 when not in RAID mode
              titan_uk

              Hi.  Looking at the manual you're right - all raid mode or not at all (chapter 4.1.3) And probably because the RAID drivers aren't booted by default unless installed in Raid mode it isn't working.  Not got this board so assuming some things but nothing here should corrupt anything - i'd backup first though.

               

              First I would ensure that my BIOS is up to date or at least version 0503.  unpack the intel drivers onto your boot drive somewhere.  Then shutdown, unplug all your raid drives.  Change BIOS / PCH config to AHCI and boot into windows.  Then try the steps here -  http://support.microsoft.com/kb/2751461. I know it's for ATA to AHCI but its the same process for raid.  Hopefully should force the basic Raid drivers on.

               

              If doesn't work can try uninstalling the AHCI SATA drivers from controllers in dev manager before going into safe boot.

               

              Or while in safe mode device manager-click top item (computer) on the right- Action-Add Legacy HW-next install manually- have disk and select the intel chipset raid drivers. reboot as per the ms article.  Possibly a repair or  2 is needed after rebooting.   Good luck

                • Re: Installing SATA RAID driver to existing Windows 10 when not in RAID mode
                  fallfrominfinity

                  BIOS shipped 0503, the newest they have available is 0601, which I can try to update to, to see if that changes anything, but that doesn't seem to have much impact on RAIDs.

                   

                  As for the kb article, Step 9 never succeeds. After proceeding through 1-7, after changing the mode to RAID on step 8, the next boot into Windows (any safe mode level) gives the same stop code of "Inaccessible Boot Device".

                   

                  And as for attempting to manually install the SATA RAID drivers - Looking through the directory of literally over a dozen INF files... C:\AMD-RAID\AMD-Chipset-Drives\Package\Drivers\SBDrv\ - everything in the "Bolton\" and "hseries\" subfolders error that they are incompatible with the system (even the ones labeled WT64A\ - Windows 10 64bit).

                  There are two other subfolders to SBDrv\ - RAID_NVMe\, and RAID_BR\. I'm not using NVMe drives (and I did make sure to download the "SATA only" version of the installer), so I assumed RAID_BR\ is the one I'm looking for. That has 3 subfolders. RAID_bottom\, RAID_cfg\, and RAID_driver\. In the latter two, cfg and driver, they each have "W7\" "W764A\" and "WT64A\" folders, each containing an INF file, SYS file and others. Attempting to add legacy drivers with the W*64A\ folders does not error that it is incompatible, however it doesn't load up a device to select to continue installing drivers. The ONLY one that did is in the "RAID_bottom\WT64A\" folder, which gave me the "AMD-RAID bottom device" driver - upon clicking "next" to start installing it, and almost immediate blue screen.I unfortunately didn't get the specific stop code, and I can't even get it from event viewer... "The system could not sucessfully load the crash dump driver" (yes, it is literally misspelled in the event viewer).

                   

                  And yes, for the sake of it, I tried changing it over to RAID mode to see if that driver would have worked, it did not.

                   

                  So after a brief system restore to remove that driver, with the assistance of a Win10 installation flash drive... We're back to the start where the OS will not boot when the controller is in RAID mode, and I can't install the RAID driver while it is not. As much as I don't want to deal with the overhead of having a software RAID, it's looking like that may be my best option.

                  It's not like the system cannot handle it; it's primarily a gaming PC so the Threadripper 1900x might be a tiny bit overkill, but the idea was to future-proof it.

                  1 of 1 people found this helpful