1 Reply Latest reply on Jun 21, 2018 1:02 AM by someguy3214

    Tried Everything. Need help. Catalyst wont recognize HD5770 anymore! FIXED!

    someguy3214

      I've practically tried everything I can think of and researched. Browsed a lot of threads on this forum and on AMD forums. I followed guides for clean uninstalling and reinstalling. (I used DDU in safe mode, AMD clean up utility, ran ccleaner etc...) Catalyst IS NOT showing graphics card options or recognizing my card but it installs fine...? I've tried three different versions of Catalyst...?

       

      System is Windows 7 64 bit. GPU is Sapphire Radeon HD5770. One day resolution got really low after I thought of updating display driver from 14.12 Omega (Been working fine for years.) to whats listed on AMD's site as last stable version 15.7 (If i remember correctly.) Didn't take, so tried installing Crimson Beta for the kicks, didn't work either. So I did a system restore after trying reverting back to what I had 14.12 and the restore worked...For a little while.


      Same thing happened again after a few days, started researching. Uninstalled drivers again using Revo Uninstaller, it cleaned up registry files and folders. Booted into safe mode, used DDU restarted, checked ALL Windows updates and installed everything it wanted me to. (There was an ATI HD5700 driver it installed along with about 40 other updates.) THEN I restarted again. Installed 14.2 Omega for windows 7 64 bit systems (Which I downloaded from Sapphires official site this time after trying AMD's version) STILL nothing.

       

      Device manager recognizes my HD5700. I tried to "Update Driver" via device manager, windows said "Most up to date version already installed" So no go there...HWMonitor detects my card and I can game on 1080p and HWMonitor shows my GPU clocks increasing, and temps heating up as usual when gaming. BIOS is set to PCI-E. I can use my HDMI cable it works but Displayport cable doesn't (No input detected message.)

       

      Anyway WHAT is going on? What else can I try? Is my card bad? If so how can I be gaming with it? Monitor is plugged into my GPU btw NOT motherboard! Should I uninstall the AMD driver windows installed? Try disabling the card in device manager and installing drivers via device manager after removing the windows installed AMD driver? Could I try my other PCI-E Slot? I've also unplugged the card and reseated it twice now also.

       

      What do I do?! Please help! Thank you for any advice!!

        • Re: Tried Everything. Need help. Catalyst wont recognize HD5770 anymore!
          someguy3214

          I FIXED IT!!!!!!!!!!!!!!!!!!!!!!! Finally! Here is what I did:

           

          After reading this thread here (Which saved my bacon):

          https://forums.guru3d.com/threads/a...bus-driver-requires-manually-updating.373501/

           

          I noticed that I DID have the old 3GIO driver in device manager. And when I tried to update Catalyst manually to newer version, this must have been why I kept getting the "Windows has determined current driver is latest version" or whatever message. So I could never update it. So I DID update that 3GIO driver to Pci Bus then tried installing Catalyst again but this is what I did wrong: I tried installing via the .EXE install file. And after that didn't work I kind of just gave up.

           

          BUT what did work is going into Device Manager, and updating the drivers for my 5700 manually and it worked! I browsed to the downloaded file of 15.2 and Windows finally took it! :D

           

          Even though I got no replies on this forum or help I wanted to post this info for anybody who does come here looking for answers to a similar problem so if it helps anybody out there: Make sure you have the Pci Bus driver installed under System Devices in Device Manager before trying to install newer version of Catalyst (That thread has the instructions.) After that is updated, manually install the Catalyst version you've selected.