1 Reply Latest reply on May 14, 2018 9:57 AM by seahawkshunt

    1600X gets stuck at 2.2GHz when changing CPU core ratio

    cakeystack

      I have been having issues trying to overclock my Ryzen 1600X. CPU-Z shows that my core speeds are working just fine with default BIOS settings. But as soon as I change the core ratio by even 0.25 or 0.50, the processor becomes locked at 2.2GHz according to CPU-Z. However, Windows and Cinebench both show that the core frequency is set to 3625 or 3650. My memory is running at its rated speed of 3000MHz (I lowered it to 2133 to see if it would make a difference, but it did not). I have my power settings set to high performance on Windows and I have tried the last 3 versions of BIOS with no positive results. I was unable to find p-state settings in my mobo's BIOS because I read in some other forums that that might be the issue.

       

      My build:

      Motherboard: Asus X370 Prime Pro

      Processor: Ryzen 1600X

      Memory: Corsair Vengeance RGB 16GB x 3000MHz

      Graphics: Radeon RX 580

      PSU: Thermaltake Toughpower 1000W

      Cooling: CoolerMaster MasterLiquid240

        • Re: 1600X gets stuck at 2.2GHz when changing CPU core ratio
          seahawkshunt

          Do Cinebench scores reflect that you are stuck at 2.2GHZ? If your CPU scores normally  2.2ghz is one of the P-states for idle/light use. If it score really low you might have a known bug.

           

           

          I have had the "multiplier"  bug since I purchased my rig 11 months ago and have scoured the internet looking for fixes. Here is what I know.

           

          A couple things here, Asus will offer 0 support with this issue. They do not offer support for overclocking.... They will refer you to the ROG forum, no "fixes" there.

           

          This is a BIOS/UEFI issue not a AMD CPU issue. In the 20 different BIOS/UEFI Asus has released for this motherboard and the other X370/B350 boards BIOS overclocking has worked with several of them. BIOS that had P-state overclocking in the AMD CBS options did not present the bug (for me). BIOS with P-states removed the bug is present. Asus has not offered P-states in their BIOS for ~4 months. Unfortunately on current Asus motherboards once you update a BIOS you cannot go back to a previous BIOS using the EZ-Flash method.

           

          It does not effect every CPU and every motherboard configuration with said BIOS/UEFI. Strange but true. I own 2 Asus motherboards and the bug is only present on 1 of them when using the same CPU with any BIOS (all BIOS released in the last 6 months). My STRIX B350-F does not have the bug and my  X370-Prime does.

           

          Most people experiencing this bug find that it triggers at a certain voltage on V-core(CPU voltage) not a certain multiplier ratio. If you are changing the multiplier and leaving the voltage at auto the BIOS  setting for vcore is triggering the bug. For me I can can go to 1.325v V-core before the bug starts to lock the multiplier. So whatever multiplier my CPU hits at this vcore is what I am stuck with (for BIOS overclocking). Try to find what v-core you can set without triggering the bug. Leave the multiplier at default(auto) and up voltage 1 tick at a time from base until the multiplier locks. Then use said voltage to find max multiplier that is stable at that voltage.

           

          The good news is Ryzen Master works fine in the OS for overclocking regardless of BIOS version. Ryzen Master allows V-core up to 1.55v (1.45v is max safe...). Just uncheck all voltage and memory options in Ryzen Master and only leave V-core and multiplier Ratio active. This way a restart is not required for overclock to take effect. Using this method I have been able to save my profile in Ryzen Master and overclock a bugged BIOS/CPU configuration as I desired.

           

          So I use BIOS for RAM overclocking and LLC settings and overclock the multiplier and vcore using Ryzen Master. I actually like this, I can activate my overclock at anytime and run stock for daily use.

          o7 Hope this helps