0 Replies Latest reply on May 14, 2018 10:37 AM by deror

    4 minutes for load Quake Champions with the amd Adrenalin edition drivers r9 380

    deror

      Hi guys since the first time i tried to run this game had 4/5 minutes of loading time for hit the main menu, then when i hit the main menu the game run fine without problems, normal loadings 70/80fps etc.

      I tried to unistall and reinstall the game, changed drivers (18.4.1 to 18.2.1 and 17.12.1 / 17.12.2) , different router, clean install of .net and c++ and a last rage format without results

      Lurking on reddit saw a topic about slow loading times with adrenalin drivers for destiny 2.. so did a last try , maybe my quake champions had the same problem? did a clean install with ddu and tried the last one crimson driver 17.11.1 before the adrenalin edition, first run in 1/2minutes, deleted old video settings files,changed back with my settings and now i can run this game with 35/45 seconds so seems the Adrenalin drivers have problems with quake champions.

      I reported that on the bethesda forum 4 minutes for load the game with the amd Adrenalin edition drivers | Community Beta for Bethesda.net  and to amd http://www.amdsurveys.com/  hope for a fix in the next drivers for the moment i have to stay with these for play this game.

       

      so:

      All the Adrenalin edition drivers need 3/4minutes for load the game

      With the crimson edition (tested with 17.11.1 - 17.11.2 - 17.11.4 - 17.10.1) i can load the game with 30/35 seconds

       

      Now with these crimson driver i can't use netflix and amazon prime video because i have the video lag bug that was fixed in the adrenalin 17.12.2 driver, i'm pretty tired with these damned amd drivers

       

      My spec:
      Windows 10 fall creators update x64

      Phenom II x 4 955be

      amd r9 380 4gb

      ssd crucial mx200

      8gb ram