2 Replies Latest reply on May 1, 2018 1:34 AM by hydrocoilette

    AMD display driver refuses to install

    hydrocoilette
      • AMD Graphics Card
        • i can't find this information, presumably because the laptop no longer even knows it's there
      • Desktop or Laptop System
        • Asus K55N
      • Operating System
        • Windows 7 64-bit
      • Driver version installed
        • at the moment, the basic Windows one. that's the problem.
        • vga.dll,framebuf.dll,vga256,vga64k
        • vgapnp.sys (6.1.7600.16385, 28.50 (29,184 bytes) 7/13/2005
      • Display Devices
        • Generic PnP Monitor
        • AMD Ambios 8bit VGA 1366x768
      • Motherboard + Bios Revision
        • (i can't find my motherboard info)
        • American Megatrends Inc. 207, 4/10/2012
      • CPU/APU
        • AMD A8-4500M APU with Radeon HD Graphics 1.90 GHz
      • Power Supply Unit  Make, Model & Wattage
        • can't find it in settings, and the sticker on the cord adapter is in both Chinese and what looks like Hebrew
      • RAM
        • 4GB

       

       

      The Issue:

       

      Originally, I had the Catalyst Control Center installed, and messed with the brightness and contrast settings. The contrast was still too high, so I went back in to change it, and the CCC would not initialize. The icon would react in my toolbar where I had it, but then it'd fade out again. No response from the program from the start menu either, though the presets still affected the picture (though not enough to lower the contrast). Watching darker shows like Penny Dreadful, most of the screen looked black. My wallpaper looked black where there should have been definition in the shadows.

       

      So finally, I looked up how to fix it. I found instructions on the AMD website on how to uninstall and reinstall the drivers. Seemed straightforward enough, so I followed the uninstall instructions, then after the laptop rebooted, I ran the auto detect utility.

       

      It appeared to have installed everything—except my display driver.

       

      I tried it a few more times to no avail. The logs simply said it failed, no error code. Here I've put the first message together with where the Fail link leads me. It looked the same regardless of what version number I tried:

       

      amd error.png

      I went through the AMD website menus to select my OS and all that, and was directed to the legacy drivers page. Tried both of those. Nothing. Tried the older and newer drivers around it just to see if they'd work. Still nothing.

       

      Along the way, I discovered my USB drivers had also been uninstalled during the original uninstall, and had to find the chipset drivers and reinstall those. That worked fine.

       

      I don't really want to try reinstalling the BIOS. I'm afraid I'll brick my computer.

       

      Tried Crimson beta again just for the hell of it. Hung at 50% for an hour. Still no display driver. Netflix runs, and so do video files on the hard drive, although the latter only plays in its lowest resolution:

       

      opm vid res.PNG

       

      edit: playing the video gave me these two errors:

       

      error.PNG

       

      error2.PNG

       

      anyway, I can't change the brightness on my screen (the slider pops up and moves but the brightness doesn't change). I can't use Windows Aero (it'll change but then when I select no sounds, the window theme switches back to Basic). Terraria (Steam game) won't run:

       

      terraria error.PNG

       

      Any other info I can provide, just let me know. I just don't know what else I can try.