0 Replies Latest reply on Apr 26, 2018 1:21 PM by ijustwanttoplayfortnite

    AMD Drivers Won't Install on Windows 10 and Black Screen on Auto-Update


      System Specs:


      20" Sceptre Gaming Monitor (X20WC 1680 x 1050)

      Ryzen 3 2200G

      Window 10 Pro

      16 GB DDR4 PC-3000

      MSI RX 560 OC 4GB

      MSI x370 Pro Gaming Carbon

      2x 240 GB SSD

      1x 480 GB SSD



      I recently have tried to install Windows 10 on a brand new system. Initially when I tried to install I would get black screens*. I had initially thought that this was due to some issue with my SSD's, my the Windows install I got, or the USB stick I used. I changed out all three but the real culprit was the interaction of my GPU and Windows.


      I installed linux (Debian 9) and was able to install and recognize the card using Mesa drivers and AMDGPU drivers (AMD does not support Debian 9 at this time). However when I tried to play Planetary Annihilation, performance was terrible. I doubt it was the card and might have been the interaction between the drivers and this particular game.


      When I got windows to run I initially couldn't update automatically windows to the most recent version (KB4093105). I had to update via the microsoft catalog. Once that update was installed I got a prompt to install a windows update provided AMD Driver

      ^(Advanced Micro Devices, Inc. driver update for Radeon RX 560 Series Last Modified: 4/24/2017 vers

      Once that was installed and I restarted my computer screen would go black as it had when I initially was installing windows. I restarted in safemode and uninstalled the RX 560 drivers in device manager. This would allow me to return to normal login desktop.

      Afterwards I tried installing the most recent drivers off the AMD website using the manual install. However whenever I run the manual installer I get a triangle exclamation in the installer saying "Unable to find drivers for this system" I have gotten this message using both the autodetect tool and the manual install package. The drivers did not install. I disable auto install of drivers via windows update and wiped it with Display Device Uninstaller. This brought me back to the Microsoft Default Display Adapter.

      When I'm in device manager I have one of three states between my Display Adapter and Monitor

      2 Display adapter Present. Both Default. One has the yellow exclamation point. Monitor is fine.

      2 Display adapters Present. One says RX 560 (this is after windows auto update^), the other is the default display adapter. *Monitor driver has a yellow exclamation point

      1 Display adapter Present. Default. Monitor driver is fine.

      *With regards to the monitor issue. I had seen on a forum that that issue could come from the monitor refresh rate being under 60hz. I did see that and changed the refresh rate and resolution but it didn't stop the black screen.

      I have also attempted to install the windows update file^ manually via the .cab file however DISM kept having errors as well.

      I have also tried switching the PCI-E ports the GPU is plugged into. It will NOT display in the Second PCI-E port. It will only push display out the first.

      I am running the most up to date BIOS. I updated it personally because I couldn't natively run my 2200g before updating the BIOS.



      The next thing I was considering was reflashing the GPU bios but there is no "update" there is on tech powerup.