4 Replies Latest reply on Apr 29, 2018 10:05 PM by khouri

    RX 580 Active DisplayPort Adapters failing after upgrading from 17.4.3

    khouri

      Describe your system:

      • Gigabyte AORUS RX 580 4GB
      • Asus M5A97 LE R2.0 Motherboard, Desktop
      • Windows 10 Pro x64 1709
      • Currently 17.4.3
      • Display Devices
        • Active DP Adapter to HDMI BenQ GW2265 #1
        • HDMI to BenQ GW2265 #2
        • DP to DVI-D to Dell 1908FP
        • Active DP Adapter to HDMI Toshiba Regza 40'' TV
      • AMD FX 8370
      • EVGA Supernova 750B 80+Bronze
      • 16GB DDR3 1600Mhz

      Describe your issue:

      • Installing any drivers past 17.4.3 resulted in any devices connected with Active Adapters to present a blue screen
      • The displays were receiving input, Windows detects the display and allows for it to be configured
      • Moved devices to different DisplayPorts and issue followed the Active Adapter
      • Rebooting into Safe Mode and Active Adapters function as intended.
      • Replacing with Passive Adapter works as expected.
      • Anything newer than 17.4.3 would not work, currently using 17.4.3 "Crimson" drivers and not the "Adrenalin" drivers
        • Re: RX 580 Active DisplayPort Adapters failing after upgrading from 17.4.3
          elstaci

          You have 4 Monitors installed on your GPU Card?

           

          can you post the Make & Model of the DP Active Adapters (v 1.2 or 1.4)?

           

          Unusual, Unless the current AMD drivers are not compatible with the older Active Adapters. Try installing the latest AMD Drivers and see if the same problem continues.

           

          Check the Resolutions under Windows Settings-Display and make sure it is correct. If you get a blue screen, try using a different Resolution and see if it has any effects.

           

          Just trying to eliminate any incorrect Resolution configuration in Windows with the Active Adapters installed.

          1 of 1 people found this helpful
            • Re: RX 580 Active DisplayPort Adapters failing after upgrading from 17.4.3
              khouri

              Thanks for your the reply elstaci.

              I'll have to double check the make/model of the Active Adapters when I get home from work.  They are likely 1.2.  I had initially purchased them for my HD 7790 when my passive Adapters wouldn't support 3 independent displays.

               

              I checked the settings in Windows and Radeon settings.  Tried adjusting the pixel format and every resolution between 800x600 and 1080p, but still just solid blue.  The monitor did recognize the state changes occurred at the driver level, the screen would go blank and come back to solid blue with the monitors OSD stating that HDMI signal was obtained.

               

              I tried the latest stable driver (I assume it's the "stable" one since it's not labelled Optional) and issue returned.  Did a clean install of latest Optional driver and issue returned.  I moved the Active Adapters to my old rig with the HD 7790 in it.  It has a the latest drivers installed and issue did not occur.  This is probably due to the card and adapters being similiar/same generation.

            • Re: RX 580 Active DisplayPort Adapters failing after upgrading from 17.4.3
              plumboby

              an idea might be try find a newer set of adaptors to suit your new card. I know these cards are [icky with certain cables. Had the boys R7 do it with a really high end HDMI cable yet threw the ceapo back in running happy as. Even had it with my dvi cable into my card port & monitor. Weird issue I have noticed to. Usually the AMD cards are realy picky on cables & crap cheap components I have found since using AMD yet some1 else could be running a near indentical build without an issue.Making me wonder has Gigabyte changed component suppliers forcing users to use specific cables to suit their cards. My boys R7 did it with a really high end HDMI cable & its a Gigabyte card to. Tho I will keep an eye out as I am about to do a R9 270 on another boys build soon & will be intrested to test being another Gigabyte card.

              • Re: RX 580 Active DisplayPort Adapters failing after upgrading from 17.4.3
                khouri

                I forgot to check the make and model of the display adapters when I got home last night.  There was a situation where the multi displays were needed and I moved some cables around.  Then proceeded with testing each driver (not including optional).  Managed to get up to 17.7.2, anything higher than that (?coincidentally? named Adrenalin) causes the problem to return.  I am going to try just using passives tonight with the latest, because if I can use those it will be essentially the same to the end users of the PC.  The adapters were bought originally for my 7790 which definitely needed Active Adapters to do 3 or more independent displays.