0 Replies Latest reply on Apr 11, 2018 7:10 AM by south

    Problems with Radeon HD 7870

    south

      Hello, Im having some problems with my card and would appreciate some help.

      First of all, the circumstances of the failure.  I put together my rig a few months back, and everything was working great upon assembly.  About 3 weeks ago however, I was playing a game when my PC froze, audio looped, and I was forced to turn it off.  Upon turning it back on, I was met with a black screen following my Mobo's Gigabyte logo.

      When the card is removed or unplugged, it boots through it with the integrated Intel graphics.  I also found that using DDU to remove all AMD drivers and stop automatic updates causes it to boot with the "Microsoft basic display adapter" listed instead of the card.  Attempting to install ANY AMD drivers causes the PC to freeze during the display driver installation portion, through the AMD software program or via device manager updates.  Attempting to let windows automatic update install the drivers caused the same thing, but with a windows crash blue screen with a string of words I cant quite remember and a =( emote.  I've tried chkdisk, sfc/scannow ect. thinking it could be corrupted parts of my HDD, and tons of other randoms things I could find online. Note that the fans spin like normal, and Ive tried switching PCIE slots to no avail. Also, I'm able to install the drivers when in safe mode, but it just results in black screen on boot again. I've tried the latest drivers aswell as a bunch of older ones, no luck.  I think it's time to ask for help.  My specs are as follows:

       

      Intel Core i5-4430 @3.0GHz

      Gigabyte GA-H87-D3H Mobo

      XFX Double Dissipation Edition AMD Radeon HD 7870

      Desktop running Windows 10 Pro 64bit

      Currently no AMD drivers installed as the black screen mentioned above, using Basic display adapter to boot through the GPU on one monitor, and the integrated Intel HD Graphics 4600 on the other.

      Corsair CX550m 550 Watt PSU

      8Gb (2x4Gb) DDR3 1600MHz Ram, Patriot Viper 3 Series Black Mamba

       

      Any help would be greatly appreciated.

      Thanks.