7 Replies Latest reply on Apr 6, 2018 12:55 PM by elstaci

    Can not change to FullHD

    dummy4711

      Hello,

       

      first of all please excuse my bad English.

       

      In Februar 2018 I buy a Desktop-PC:

       

      Windows-Version:                          Windows 10, Professional, 64 Bit
      CPU/APU-Typ:                              AMD A12-9800E RADEON R7, 12 COMPUTE CORES 4C+8G

      Grafik:                                            AMD Radeon R7 Graphics

      Driver version:                            23.20.15017.3010 (Date 31.01.2018)
      Mainboard:                                     Asrock A320M-HDV
      BIOS-Version/-Date:                      American Megatrends Inc. P4.40, 02.01.2018
      Power Supply Unit:                    500W
      Memory:                                         8192 MB DDR4, 2400MHz
      Monitor:                                          AOC - TFT 24W 80 PSA
      Connected:                                     
      VGA

       

      There is no way to change the Graphic-Resolution to the from the AOC-Monitor recommanded 1920x1080 Resolution Mode.

       

      The 1600x1200 Mode didn't sync so the max I can only use is the 1440x900 resolution.

      GrafikKartenTreiber.pngMonitorTreiber.png

       

      The Monitor has only a analog VGA connector whitch works 8 years perfect with Windows-XP and 1920x1080 pixel.

       

      On a 4K-TV the PC works over HDMI even in UHD Resolution.

       

      „MonInfo.exe“ shows that the Monitor Data was detected and the stored in the Registry.

      MonInfo1.png

      MonInfo2.png

       

      So the Hardware can the FullHD, the Monitor can FullHD, why not the Driver?

      Do I somethig wrong or why can I not use the 1920x1080 Resolution?

       

      Thanks a lot for helping.

       

       

       

       

       

       

       

       

       


        • Re: Can not change to FullHD
          pokester

          Your hardware and the drivers for the APU and MB absolutely support 1920x1080p.

          Question is why isn't it?

           

          A few possibilities to look at.

           

          Do you have or can you borrow another monitor know to be working fine at 1080p to try with your computer? Maybe a friend, neighbor or family member if you don't have another.

           

          I think I would try this before messing with anything else. If that monitor works then you know where the problem isn't.

           

          Now try your monitor on the other PC that you borrowed the monitor from and see if 1080p works there. If your monitor doesn't work at 1080p on the other computer either. It probably doesn't support it or maybe a bad cable or a port on the monitor went bad. if you have another port like DVI or HDMI to try do that if you can. They are better connections anyway. I know you believe the monitor supports 1080p ( and it may very well support it ) based on what you circled above. But that Generic PNP Driver is a one size fits all driver for monitors and that resolution being listed doesn't mean your monitor supports it, it means the driver does.  I tried to find your monitor from your information but could not.

           

          If both those work however then your problem isn't the monitors.

           

          next or you could start with the following too if getting a second monitor is an issue.

           

          Then you may wish to reinstall your driver again. You can pickup the current driver here  Support page | AMD

           

          From there if that does not work you may need a bios update to that MB. I would talk to Asrock support at that point and get their advice, tell them what you told us and what you have done. They will steer you in the right direction as to performing a Bios update if needed.

           

          I personally don't ever recommend doing bios update unless you have an issue that can't be resolve another way. Not to scare you but they can go wrong.

           

          Let us know if any of this helped or not. We can keep trying if needed.

           

          Good Luck!

            • Re: Can not change to FullHD
              dummy4711

              Hello Pokestar,


              thank you for your detailed answer. Meanwhile I connected the monitor to the olde XP system and it worked flawlessly.

               

               

              Before I contacted the AMD forum, I already asked the Microsoft Forum.

              Since I assumed that Windows installed the wrong monitor driver because the Windows Device Manager showed "generic PnP monitor ", I assumed a problem with the monitor driver. In the Microsoft-Forum , I was given a logical answer:

              Original in German:

              Der Monitor liefert über PIN 4+11+12 des VGA-Anschlusses und des Kabels zum gleichen PIN der Grafikkarte die Identifizierungsbit. Damit übermittelt der Monitor alle notwendigen Angaben inklusive Hersteller, Typ, Bezeichnung und so weiter inklusive welche Auflösungen dieser Monitor kann. Diese Infos werden dann von den konkreten Treibern der Grafikkarte ausgewertet und als Auswahlmöglichkeit angeboten. Deshalb ist ein Treiber des Monitorherstellers zum Thema Auflösung grundsätzlich überhaupt nicht erforderlich, es sei denn der Hersteller hält sich nicht an die Standards. Der "Treiber für den Monitor" ist eigentlich nur erforderlich für Fragen des Farbabgleiches und ähnliches - stark vereinfacht formuliert.


              Try to translate in English:

              The monitor delivers via pin 4 + 11 + 12 (plus 15 supplemented by me) of the VGA connector and the cable to the same pin of the video card the Identificationbit. Thus, the monitor transmits all necessary information including manufacturer, type, designation and so on including which resolutions this monitor can. This information is then evaluated by the specific drivers of the graphics card and offered as a selection option. Therefore, a driver of the monitor manufacturer on the subject of resolution is generally not required at all, unless the manufacturer does not comply with the standards. The "driver for the monitor " is actually only required for color matching and similar-much simplified wording.


              As shown in the above pictures (to the tool "MonInfo. Exe" ) and the following Pictures, any driver has retrieved this monitor data and stored it in the registry.

              In my opinion, the "AMD Radeon R7 Graphics" driver does not access this data or it cannot read the monitor identification data. Some driver has the done this otherwise they were not in the registry

              Registry.png

              The monitor has supplied the data, they are in the registry but they do not appear to be processed by the graphic driver.

                • Re: Can not change to FullHD
                  pokester

                  Everything you said I believe is correct. Now the explanation on the Generic PNP driver is true but it is a perfect world scenario too. Many monitors do have issues with the standard. Not intentional but it happens frequently and monitor makers will fix this with a custom driver, unfortunately lately MS keeps replacing these with the Generic PNP, should be fine does not always = is fine. I have seen sleep issues and mhz issues being most common with this. I however don't think that is an issue at all in your case and very much trust the Generic PNP is fine.

                   

                  I am really thinking at this point the problem is definitely in one of 2 places either as you said the driver or bios related on the Motheroard. As I suggested before I would talk to Asrock about this issue. They may already know about it and have a fix or at least be able to tell you where the problem is, driver or bios or something different. I wold definitely open a support ticket with AMD about this issue too. Not that someone here might not have better advice, but it seems you really do have an issue worth requesting official help and the forums here are just your peers helping, not AMD employees. Open a ticket here: Email Form

              • Re: Can not change to FullHD
                elstaci

                What does Windows 10 Settings under "Display" show as "Recommended" Resolution for your monitor?

                 

                If it shows 1440x900, then try to change it to a higher resolution if it shows it. When you try a higher resolution, your screen will go black and then come back on. If it stays Black, just wait a few seconds and it will automatically return to the original Resolution, as long as you don't click " Keep Resolution".

                 

                Went to Asrock Support for your Motherboard here : ASRock > A320M-HDV .

                 

                You have a very new BIOS for your Motherboard. Maybe updating to the latest BIOS may help with your problem:

                 

                BIOS - 4.70 - 03/06/2018

                 

                This is the correct APU Driver for your A Series R7 from 02/2018: APU . By the driver you posted, it seems to be the wrong one for your APU. I think you downloaded the driver for the dGPU and not the APU. I can't seem to locate a driver with that date 01/31/2018.

                 

                By the way,

                 

                Found the German Microsoft Forum you first asked help for: Keine 1920x1080 Einstellmöglichkeit bei VGA-Monitor - Microsoft Community . I translated it into English. They give a lot of Info.

                1 of 1 people found this helpful
                  • Re: Can not change to FullHD
                    dummy4711

                    Hello @elstaci, hello @pokestar,

                     

                    first of all, thank you very much for your help and the time you have sacrificed me.

                    In the meantime I can use the 1920x1080, 60hz resolution.

                    In case someone else has the same problem, I show in the following how I proceeded:


                    I had already seen that I can enter a custom setting in the "Radeon settings", but was initially anxious, since I had read, at least in the CRT age, wrong timing can destroy the monitor.

                    Radeon 1.png

                    Although I know the theory and black shoulder are no foreign term. But who has the exact timing for FullHD, 60 Hz in mind.

                    But then I learned from the tool "Cru. exe" and

                    CRU.png

                    that there the timing such as "automatic LCD standard" are specified or calculated.

                    CRU1.pngCRU0.png

                     

                    So I entered my resolution and transferred the values to "Radeon settings"

                     

                    Radeon 3.png

                    and got a heart attack as the monitor became black after it was confirmed.


                    After the reset, Windows went up again in the old 1440x900 setting.

                    The 1920x1080, however, now appeared in the "Ad setting" and worked flawlessly this time.

                     

                    An uneasy feeling remains, because I have no idea whether this is the right or the optimal settings. So I have no idea what the different "automatic LCD-Reduced" setting causes.

                    Leaving these attitudes to a non-professional person already carries an adventurous optimism.

                     

                    Many thanks to the safe islands in the ocean of unknowingness.

                    Thx_e.png


                    @elstaci,

                    I am pleased that you have found useful information from the German forum. I'm too.

                    Without the note that even analogue monitors send your data via an I2C bus I would have given up and would have bought me grudgingly a new monitor.

                    2 of 2 people found this helpful
                      • Re: Can not change to FullHD
                        pokester

                        You know had you had this issue 15 years ago I would have had a utility like the one you have found to fix this to reccomend. Having to make a custom resolution in the old CRT days before the modern standards was a very common thing. It didn't even dawn on me in today's world. Thanks so much for the share and I definitely am going to grab that utility to put back in my digital toolbox. So glad you are taken care of and it feels great when you figure it out yourself too!

                         

                        Take care it's been a pleasure!

                        • Re: Can not change to FullHD
                          elstaci

                          by the way,

                           

                          Mark your last post (with your fix) as the CORRECT answer. So others will know that your problem has been fixed and how.

                           

                          Good troubleshooting.

                          1 of 1 people found this helpful