67 Replies Latest reply on Jul 12, 2018 6:35 PM by ren34

    Is Freesync no longer supported for Samsung CF791?

    ciscoh

      So I bought my Vega 64 and Samsung CF791 monitor in the deals when they were first launched.

      Since 18.1.1, it seems I lost Freesync when using a Displayport cable (tried numerous cables, same result with each). I then moved onto HDMI. At this time I changed to a Vega 64 LC. Then since 18.2 roughly, It seems I have lost Freesync all together.

      It's definitely a software issue as reinstalling 18.1.1 gives me nice smooth Freesync game play.

      At the moment I get ''less'' tearing using HDMI, and unbearable tearing with Display port.

      If it's no longer being supported, why would AMD market this monitor with the launch of Vega?

      To confirm: Freesync Ultimate Engine is enabled on the monitor. Freesync is ''ON'' on Radeon Settings. I've experimented with Chill and FRTC, but these remain off. I've experimented with individual game profiles with AMD optimized Freesync and Freesync ON.

        • Re: Is Freesync no longer supported for Samsung CF791?
          mungo

          Hi. You are not alone with this issue. I created a similar topic in this forum and i submitted a Supportticket at AMD Support. So far so bad.

          • Re: Is Freesync no longer supported for Samsung CF791?
            jd9786

            I as well can't get freesync to work on the newer drivers using the CF791. I believe it's an issue though and not lack of support, because you are still able to turn on freesync in the radeon settings, it just makes no difference.

            • Re: Is Freesync no longer supported for Samsung CF791?
              fuzzmunky

              Freesync issues continue not just on this monitor but on the Nixeus EDG27.

              It may have something to do with multimonitor setup... maybe. I only say that because that is my setup and it was mentioned in a previous bug fix.

              • Re: Is Freesync no longer supported for Samsung CF791?
                fuzzmunky

                I seem to have fixed Freesync with the help of Mr Nixeus.


                He mentioned something about Game DVR, but in the Fall Creators Windows 10 update the Game DVR setting doesn't seem to work. I went into the registry to turn it off using these instructions.

                 

                Open Registry Editor (Run > regedit)

                Navigate to HKEY_CURRENT_USER\System\GameConfigStore

                Set the value of DWORD "GameDVR_Enabled" to 0

                Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\

                Create key "GameDVR".

                Create DWORD 32bit called "AllowGameDVR" and set to 0

                Restart your computer.

                 

                After this, my Freesync in games and in Gsync demo is working again in 18.3.4

                The windmill demo still does not work however, but I am told this is because that was old software that doesn't do freesync the way it is programmed now.

                 

                Please let me know if this fixes it for you Samsung users, and maybe amdmatt, you could look into why this is happening?

                  • Re: Is Freesync no longer supported for Samsung CF791?
                    elstaci

                    FYI:an OPS at Nvidia made up a script to disable GAMEDVR and XBOX. One of the expert commentators says it is risky to use and may open Windows to virus/malware. Don't know if this is factual or not. Anyways here is the script from Nvidia:

                    Hello everyone,

                     

                    I have re-posted this here as it made more sense. You can't update drivers to fix this. It takes a lot more to undo the changes in the Win 10 Creators update that are causing so much grief. But there is a fix. To make it quick and simple I wrote a script that does all that is required.

                     

                    There have been many posts claiming to have a fix. In most of these I have seen some really bad advice on what is wrong and how to fix it.

                     

                    If you want to fix this issue once and for all. You don't need to remove your drivers, download any shady apps or wreck your folder permission to fix this. The script I provided is safe. It only changes what is required to undo the root of the problem. The instructions are below. The script must be run in the order top to bottom. So please make sure your first line is ( and the last line is ). This makes it run in series. There is no fat. Every line is required.

                     

                    Simply turning off the XBOX related settings does not stop the "GameBarPresenceWriter.exe" from running while gaming. The script below can be copied and pasted into an admin CMD window or if you have powershell as the default open a powershell admin command-line and type CMD then press enter. Then paste the code below to run. You can also just save it as a .BAT and run as Admin.

                     

                    This has fixed The division, Wild-lands, Rocket league, and Doom for me. I have not had the issue return either I might add!

                    Gaming is as smooth as ever for my friends and family. If the direction are still too hard to understand you might want to ask a "Tech" friend to assist you.

                     

                    If a game is still giving issues after running the fix, please post here PM me and maybe I can help you work out why.

                     

                     

                     

                    REM --- copy from here-----

                     

                     

                    (

                    reg add "HKLM\System\CurrentControlSet\Services\xbgm" /v "Start" /t REG_DWORD /d "4" /f

                    sc config XblAuthManager start= disabled

                    sc config XblGameSave start= disabled

                    sc config XboxGipSvc start= disabled

                    sc config XboxNetApiSvc start= disabled

                    schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Disable

                    takeown /f "%WinDir%\System32\GameBarPresenceWriter.exe" /a

                    icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /grant:r Administrators:F /c

                    taskkill /im GameBarPresenceWriter.exe /f

                    move "C:\Windows\System32\GameBarPresenceWriter.exe" "C:\Windows\System32\GameBarPresenceWriter.OLD"

                    schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Disable

                    takeown /f "%WinDir%\System32\bcastdvr.exe" /a

                    icacls "%WinDir%\System32\bcastdvr.exe" /grant:r Administrators:F /c

                    taskkill /im bcastdvr.exe /f

                    move C:\Windows\System32\bcastdvr.exe C:\Windows\System32\bcastdvr.OLD

                    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "0" /f

                    reg add "HKCU\Software\Microsoft\GameBar" /v "UseNexusForGameBarEnabled" /t REG_DWORD /d "0" /f

                    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AudioCaptureEnabled" /t REG_DWORD /d "0" /f

                    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "CursorCaptureEnabled" /t REG_DWORD /d "0" /f

                    reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "0" /f

                    reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "0" /f

                    reg add "HKLM\Software\Policies\Microsoft\Windows\GameDVR" /v "AllowgameDVR" /t REG_DWORD /d "0" /f

                    reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "0" /f

                     

                    )

                     

                     

                    REM ---End Copy Here---

                     

                    This RE-ENABLE GAMEDVR/XBOX script was made by another User after I made a comment about undoing what the first script had done to the Registry:

                     

                    A couple of corrections have been made to the script to re-enable Game Bar / Game DVR folks... I had some things backwards but it's working 100% now, I've tested it. Windows Update won't know the difference, because it also restores the original permissions and ownership to the files affected. You will need to restart your computer, though.

                     

                    • @echo off
                    • goto check_Permissions
                    • :check_Permissions
                    •   echo Administrative permissions required. Detecting permissions...
                    •   net session >nul 2>&1
                    •    if %errorLevel% == 0 (
                    •   echo Success: Administrative permissions confirmed.
                    • move "C:\Windows\System32\GameBarPresenceWriter.OLD" "C:\Windows\System32\GameBarPresenceWriter.exe"
                    • icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /setowner "NT Service\TrustedInstaller" /c
                    • icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /grant:r Administrators:RX /c
                    • schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Enable
                    • move C:\Windows\System32\bcastdvr.OLD C:\Windows\System32\bcastdvr.exe
                    • icacls "%WinDir%\System32\bcastdvr.exe" /setowner "NT Service\TrustedInstaller" /c
                    • icacls "%WinDir%\System32\bcastdvr.exe" /grant:r Administrators:RX /c
                    • schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Enable
                    • sc config XblAuthManager start= auto
                    • sc config XblGameSave start= auto
                    • sc config XboxGipSvc start= auto
                    • sc config XboxNetApiSvc start= auto
                    • reg add "HKLM\System\CurrentControlSet\Services\xbgm" /v "Start" /t REG_DWORD /d "3" /f
                    • reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "1" /f
                    • reg add "HKCU\Software\Microsoft\GameBar" /v "UseNexusForGameBarEnabled" /t REG_DWORD /d "1" /f
                    • reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AudioCaptureEnabled" /t REG_DWORD /d "1" /f
                    • reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "CursorCaptureEnabled" /t REG_DWORD /d "1" /f
                    • reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "1" /f
                    • reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "1" /f
                    • reg add "HKLM\Software\Policies\Microsoft\Windows\GameDVR" /v "AllowgameDVR" /t REG_DWORD /d "1" /f
                    • reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "1" /f
                    •    ) else (
                    •   echo Failure: Current permissions inadequate.
                    •    )
                    •   Pause > null

                    If you had attempted to use the re-enable script previously, you'll need to run the disable script again, then the updated re-enable script for it to finally be successful.

                  • Re: Is Freesync no longer supported for Samsung CF791?
                    ciscoh

                    Just wanted to update with my specs.

                    System Configuration:

                    Motherboard: MSI Z97i Gaming ACK (Bios: A.4)
                    CPU: Intel i7 4790k
                    Memory: 16GB DDR3
                    GPU: MSI Vega 64 LC
                    VBIOS: 115-D0500500-103
                    Driver: 18.3.4
                    OS: Windows 10 Home, Ver: 1709, OS Build: 16299.309

                    Monitor: CF791 Samsung

                    Steps to Reproduce:

                    1. Install necessary driver, GPU and medium-end CPU
                    2. Enable Free Sync
                    3. Any Graphical Setting
                    4. Screen Tearing experienced
                    5. Most noticeable with HDMI than DP

                    Expected Behavior:

                    Game runs smoothly with good performance with no visible issues

                    Actual Behavior:

                    Constant Tearing, oddly more visible on DP than HDMI

                    Tried Samsungs ''driver'' for the monitor, this creates a 'purple filter' across the screen. Tearing still apparent. Currently using the ''Generic PnP'' for the monitors as samsung' seems to make 0 difference. Patch 18.1.1 is the last working patch for me with Freeesync.

                    • Re: Is Freesync no longer supported for Samsung CF791?
                      jd9786

                      Any updates guys? Is this issue being looked at, is there anything else we need to share?

                      • Re: Is Freesync no longer supported for Samsung CF791?
                        mungo

                        Maybe we should start to compare our Firmwareversions for the CF791. It seems there was a Firmwareupdate by Samsung last Year.

                        • Re: Is Freesync no longer supported for Samsung CF791?
                          jd9786

                          Couldn't find anything related to the firmware either. But it seems there are different models. Mine is LC34F791WQUXEN, but there is also LC34F791WQNXZA. What model do you guys have?

                          • Re: Is Freesync no longer supported for Samsung CF791?
                            jd9786

                            I'm not sure the problem is on Samsung's side. I mean freesync works perfectly fine in 17.12.x versions. It only stopped working in the recent updates (from 18.x.x and up i think). What makes this confusing though is that not everyone is experiencing the problem. And if engineering can't reproduce it, obviously they can't fix it.

                             

                            Hate to say it, but I think we're running out of luck...

                            • Re: Is Freesync no longer supported for Samsung CF791?
                              galimate

                              Hi, I experienced the same problem with the same solution: my Vega 56 on a LG 27UD58 could not do freesync under the newest Adrenalin drivers (18.2.1 and 18.3.4), but after a little research I found that others had the same problem and uninstalling the Adrenalin driver with DDU and installing 17.11.4 Crimson did solve the problem, now the Freesync works. Here is the post  where I found the solution: https://www.reddit.com/r/Amd/comments/88suo1/is_freesync_no_longer_supported_for_samsung_cf791/

                               

                              I previously owned a R9 390 with the same monitor and a crimson driver (cant remember which but I used it June-July 2017 and assume with the latest drivers) and the freesync worked fine.


                              Please AMD investigate where lies the problem in your drivers because I'm pretty sure that a lot more people have the same problem, they just don't bother to research and post about it.

                              1 of 1 people found this helpful
                              • Re: Is Freesync no longer supported for Samsung CF791?
                                mungo

                                AMD are you still into this?

                                Any news about it?

                                  • Re: Is Freesync no longer supported for Samsung CF791?
                                    amdmatt

                                    I have created a ticket with engineering and they are looking into it. The problem is we don't have very many reports, just a few users with this monitor, and i myself have not been able to reproduce the issue despite having the same monitor and graphics card. I'll update the thread if and when i have anything to share.

                                      • Re: Is Freesync no longer supported for Samsung CF791?
                                        amdmatt

                                        Just an update, we are still looking into this issue.

                                          • Re: Is Freesync no longer supported for Samsung CF791?
                                            wechhe

                                            See below answer on how I solved the "Freesync not working issue" by activating Vsync.

                                             

                                            amdmatt - What is the status of this issue? When using google I find more people complaining about this in different forums.

                                             

                                            I have a C34F791 with a Vega 64 Liquid Cooled via HMDI 2.0 and the same issue. Since beginning of the year Freesync is not working correctly - I still have Tearing and stuttering. Games are WoW, Pubg, GTA V, Battlefield 1 and some smaller Steam games.

                                             

                                            edit:

                                            I tried 18.1.1 / 18.2.1 / 18.3.1 / 18.5.2 - Freesync doesn't work and still occasional black screens happen

                                            I reset my monitor - nothing changed.

                                            I tried different settings in games and drivers - no changes

                                             

                                            --> I switchted to 17.11.4 (same for 17.12.2) and FREESYNC WORKS. (wow - what a smooth gameplay!!)

                                             

                                            So this is obviously an issue with the Adrenaline 18.x.x drivers as reported in this thread and other threads on the Internet.

                                             

                                            Dear AMD, dear amdmatt - please fix this issue.

                                             

                                             

                                            My guess:

                                            In all the 18.x.x drivers I have no Freesync Flickering. With 17.x.x I do have flickering. Maybe that is connected?

                                             

                                            Steps I took (for you to reproduce?)

                                            - uninstall existing AMD drivers using Windows/programs & restart

                                            - using amdcleanuputility & restart

                                            - installing new driver with all except the Bethasomthing launcher

                                            - enabling HBCC to 11786 MB

                                            - enabling FRTC to 98 FPS

                                            - loading Wattman profile (P6 1100mV / P7 1150mV / 1120 MHz HBM / 950mV HBM / target temp to 60°C / Powertarget +40%)

                                            - loading Samsung Monitor driver for HDMI 2.0

                                            - restart PC

                                            - start game World of Warcraft since it has lots of tearing usually

                                            ####################

                                             

                                            My PC:

                                            Windows 10 x64 Pro 1803 (same issue before creators update)

                                            AMD Ryzen 1700x on Asus Crosshair VI

                                            BeQuiet Dark Power 850W

                                            16 GB FlareX RAM

                                            Vega64 Liquid Cooled

                                            Samsung 34CF791 with Freesync Ultimate enabled / Gaming mode off and using the Samsung driver

                                            HDMI 2.0 cable

                                            HBCC on/off makes no difference

                                             

                                            Do you need any additional information? What can I / the community do to support with the analysis?

                                              • Re: Is Freesync no longer supported for Samsung CF791?
                                                wechhe

                                                After extensive testing and reading through forums I found information about Freesync and Vsync. From previous days I remember that Vsync is bad because it adds a lot of Input Lag and the mouse movement doesn't feel that direct. Therefore I never used Vsync.

                                                When I finally got Freesync with my Vega 64 and CF791 I again did not activate it. With Freesync activated and FRTC set to 98 Hz I enjoyed perfectly smooth gameplay without tearing as advertised by AMD until driver version 17.12.2.

                                                 

                                                With 18.1.1 it seems that some changes have been introduced to Freesync - without Vsync activated I have Tearing in all games. Activating Vsync solves that problem. (or me at least).

                                                With Freesync active, Vsync works differently. It eliminates the tearing completely without additional Input Lag. And it works as a FPS Limiter so you always stay within Freesync Range (top end at least).

                                                 

                                                Open questions - answer appreciated:

                                                1.) If FPS = Monitor refresh rate (Hz), do I then have the extra Input Lag? So is it recommended to use a FPS limiter to never hit the monitor's refresh rate?

                                                2.) Is the following true?

                                                Using Frame Rate Target Control (FRTC) in the Radeon Settings to limit the FPS to stay within Freesync Range adds a similar amount of input Lag as VSync according to "the internet". Use the ingame settings / configs to limit the FPS instead. If not possible, use the tool RTSS (Riva Tuner Statistics Server).

                                                 

                                                TLDR;

                                                - Activate Freesync in Monitor, check in Radeon Settings if Freesync is active

                                                - Activate VSync in the Game Options if you still experience tearing. (if ingame not possible, use Radeon Settings)

                                                - (optional) Use ingame Frame Limiter or RTSS / FRTC to prevent the FPS hitting VSync. (see above questions)

                                                - Enjoy smooth Gameplay.

                                                 

                                                amdmatt

                                                Is it possible to provide this information to the users? I mean others than in some forums? I cannot find this information in the Radeon Center nor in my GPU manual (who reads manuals anyway...). And I find many people asking the same questions; having the same confusion as I did for not using VSync.

                                                Providing the AMD customers with the needed information is a WIN-WIN-Situation!!

                                                For the Customer - they enjoy smooth gameplay as advertised

                                                For AMD - you guys have less unnecessary support work and can deal with the real problems

                                                 

                                                I can imagine having a tutorial / information window within Radeon settings explaining all the different settings and their effect. I guess Chill, EnhancedSync and the others also are not easy to understand for many users.

                                                • Re: Is Freesync no longer supported for Samsung CF791?
                                                  elstaci

                                                  If you want you can delete this post. Click on "Actions" and then click on "Delete".

                                            • Re: Is Freesync no longer supported for Samsung CF791?
                                              jd9786

                                              mungo do you also have a black screen/signal loss issue? And are you using DP or HDMI?

                                            • Re: Is Freesync no longer supported for Samsung CF791?
                                              ciscoh

                                              I recently tried to go back to display port cable to see how freesync was on that but when I open a game, such as league of legends, the screen goes blank, and cuts out and I can only view league with freesync disabled. on 18.4.1 at the mo.

                                              • Re: Is Freesync no longer supported for Samsung CF791?
                                                piti

                                                So i have a Gigabyte RX Vega 64 OC and a CF791.

                                                 

                                                I ran in some serious bugs with this setup.

                                                 

                                                1. Drivers 18.5.1 and 18.5.2 give me a framelock at 75 fps with freesync and vsync or enhanced Sync on. With vsync off framelock is gone but stuttering occurs.

                                                 

                                                The 75 Fps lock with Vsync and Freesync can only be fixed for me when i downgrade to Driver 17.12.2. (Haven´t tried other 18 Drivers besides 18.5.1 and 18.5.2)

                                                 

                                                2. When im fresh booted and i start a windowed application like Valley Benchmark the sytem gets total unresponsive. Hardwaremonitoring laggs like hell and i cant      click things on the taskbar. The funny thing is when i turn the CF791 off and on the lag problem ist gone till i reboot.

                                                 

                                                Resolved the lag issue by uninstalling Roccat Swarm Software.

                                                 

                                                The system lag issue still there. i found its a windows 10 1803 problem. I downgraded to build 1709 and the lag was gone. Testet an entire day. Tried 18.5.1, 18.5.2 and 17.12.2 no lag with 1709 in windowed mode.

                                                 

                                                3. Im now running  17.12.2 drivers. The framelock is gone. Freesync is smooth. But i have this stupid blackscreen issue via DP.

                                                 

                                                 

                                                 

                                                All testet on fresh Install of windows 10 pro 1803. Freesync Engine setting Standard or Ultimate makes no change to the Problems.

                                                 

                                                Hope this helps a little to find a fix.

                                                 

                                                thx

                                                • Re: Is Freesync no longer supported for Samsung CF791?
                                                  jd9786

                                                  Any news yet? At least if AMD could fix the tearing/freesync i would be really grateful. The black screens is not so big of an issue as i'll be switching to HDMI 2.0 when i get a new gpu anyway.

                                                  • Re: Is Freesync no longer supported for Samsung CF791?
                                                    ren34

                                                    Freesync still broken on 18.7.1.  Sigh..