13 Replies Latest reply on Mar 31, 2018 2:11 AM by saulkr

    radeon settings are currently not available

    saulkr
      • AMD Graphics Card
        • MSI RX560 AERO ITX 4GB OC
      • Desktop or Laptop System
        • HP 280 G1 MT
      • Operating System
        • Windows 10 64bit
      • Driver version installed
        • Radeon Software adrenalin edition 18.2.3 (downloaded from MSI site, also tried newer one directly from AMD)
      • Display Devices
        • Samsung LED PLS S24F350FH 23.5 inch connected via HDMI
      • Motherboard + Bios Revision
        • I don't know how to find my motherboard's model or bios revision.
        • intel pentium g3250
      • Power Supply Unit  Make, Model & Wattage
        • Corsair cx450m 450W
      • RAM
        • 10GB

       

      Issue:

      I bought a new RX560 card with a new 450W PSU, I putted everything into my system and downloaded the correct drivers (I hope) and installed them.

      Restarting my pc and attempting to open radeon settings, it shows this frustrating message:

      "radeon settings are currently not available please try again after connecting amd graphics"

      I have reinstalled windows and tried to install the drivers again but nothing changed, still stuck with this one.

      I am 300% sure that my monitor is plugged into the graphics card itself and not into the motherboard.

      (I don't know why but when i tried plugging it to my integrated graphics it didn't display anything, maybe it lacks the intel driver?)

      Edit: I have tried this guide Clean Install AMD Graphics Drivers and reinstalled the driver, it's changed the error message to:"no amd graphics driver is installed or the amd driver is not functioning properly etc."

      I have updated windows with upgrade assistant and windows update and windows update downloaded a driver for the GPU, maybe This what causes the problem now?