15 Replies Latest reply on Apr 15, 2018 9:14 AM by hardcoregames™

    Crysis 3 huge FPS drops

    shadowdevgamer

      Hi there,

       

      I've got a problem running Crysis 3. In some scenes my fps suddenly drops from constant 60 (V-Sync enabled and locked at 60) to 23 or lower.

      I also noticed that the same problem might be occuring in this video, too: [1080p] GTX 1070 Ti vs Vega 56/ Vega 64/ GTX 1070/ GTX 1070 Gaming Benchmarks! - YouTube

       

      My hardware:

      Windows 10 Pro (1703, x64) and Windows 10 Pro (1709, x64)

      Intel Core i7-6800k (x64)

      AMD Vega 64 (Air cooled)

      32GB DDR4 RAM

       

      I also have to note that the game ran fine with my old GTX 960 (same game and Windows version). Since than I changed nothing except for the switch to AMD and it's Vega 64.

       

      Tested driver versions:

      17.11.1

      18.3.3

      18.3.4

       

      Here are the different settings I tested the Game with:

      Resolution: FHD; 1920x1080 (Fullscreen Mode)

      Antialiasing: SMAA-Low (1x) and with MSAA High (8x) and with FXAA but also with Disabled

      Texture Resolution: High and with Very High

      V-Sync: ON and OFF

      Game Effects: Very High and Low

      Object: Very High (and Low; see below)

      Particles: Very High

      Post-Processing: Very High

      Shading: Very High

      Shadow: Very High and Low

      Water: Very High

      Anisotropic Filterung: 16x

      Motion-Blur Amount: Medium

      Lens-Flare: Yes

       

      I have to notice that changing the setting Object from Very High to Low gives me a significant performance boost (up to 15fps at best more; depending on the scene in which the problem occurs), but the fps drop is still noticeable, especially in the one scene I ran nearly all my tests with.

      Intel Turbo Boost is enabled in my BIOS and my CPU clock is set to 3.8GHz for all cores.

      The problems also occur with the default clock from 3.4GHz of my CPU.

       

      A fresh installation of Windows 10 and all it's drivers and the Game through Origin doesn't solve this problem.

      Someone on the ComputerBase forum noticed that the memory clock speed is too low. The problem with this: When I'm getting 60fps it's not too low.

       

      I attached some pictures showing the problem, always one picture showing Crysis 3 without problems and one picture showing it with the problems.

      Disabling Hyper-Threading or multiply CPU cores and hyper threading also didn't solve this problems while testing the same scene on an PC from a friend of mine with an GTX 660 (2GB VRAM) and an older i5-3570k @3.40GHz (not overclocked while Intel Turbo Boost is enabled) with a newer Windows 10 version and 8GB DDR3 RAM didn't showed this problem.

       

      For creating these pictures I used for the newest pictures MSI Afterburner (newest version) with the following settings enabled (OSD):

      • GPU temperature
      • GPU usage
      • Memory usage
      • Core clock
      • Memory clock
      • CPU temperature and usage and clock speed
      • RAM usage
      • Framerate
      • Frametime

       

      Note: The "hp" within the picture name means no hyperthreading (but all cores enabled). The "4cores" means that I disabled all cores except for 4 cores in my BIOS and I disabled hyper-threading, too. Pictures from 2017 and the FXAA and supersampling pictures have been created with the 17.11.1 driver. The supersampling means that I changed the Anti-Aliasing method within the game's profile in Readon Settings to Supersampling.

      For all pictures ecept the supersampling picture, no settings in the Readon Settings Profile have been changed which means that all default AMD optimized settings are turned on.

       

      EDIT: Here is a small video showing the problems I've got:  Crysis 3 FPS drops - YouTube

      Note: I've removed some scenes from the captured content to keep the video as short as possible. The video contains two runs, the first one with Hyperthreading disabled and all cores enabled and the second run with Hyperthreading disabled and 4 cores enabled. Intel Turbo Boost 3.0 was enabled the whole time! The video may have stuttering in it at some points, so just take a look at the FPS indicator.

       

      Changing the settings Game Objects and Shadows to Low results in more than 60fps while the problem still persists. It's just no longer noticeable on a 60Hz monitor.

       

      Message was edited by: shadowdevgamer Added a video showing the problem and additional details while also updating the hardware and settings list.

        • Re: Crysis 3 huge FPS drops
          hybrid

          Hello,

          I think the culprit is V-sync,

          V-sync locks the FPS to 60 or 30,

          If the FPS drops slightly below 60 FPS,then V-Sync will lock the FPS to 30 FPS,stuttering in the process.

          AdaptiveVSync-1-650.png

          and i recommend changing MSAA to x4.

           

          Please let me know if i helped.

            • Re: Crysis 3 huge FPS drops
              shadowdevgamer

              Ok, I tested it again with disabled V-Sync and disabled Antialiasing.

              However, the problem still remains. I would even go as far as to say it made it worse:

              Now the fps drop isn't from 60 to 25 but from nearly 120 to 25. With Objects set to Low

              my fps go down to ~36 instead of ~25 (tested multiply times).

              • Re: Crysis 3 huge FPS drops
                shaoaz

                Those V-Sync problems only occur at Double Buffer OpenGL. That's why there is a OpenGL Triple Buffering option in AMD's panel. V-Sync never cuts the framerate in half on DirectX games, there has been a few cases but it's quite rare and switching to Triple Buffer fixes it anyway.

              • Re: Crysis 3 huge FPS drops
                shadowdevgamer

                I tested it now again with Windows 10 1709 x64 and the problem still persists.

                  • Re: Crysis 3 huge FPS drops
                    Hardwood

                    My RX580 has problems with crysis 3 too. I ended up setting it to Global lowest and adding improvements 1 at a time.

                    To my old eyeballs the game looks really good even though a lot of the settings are still on low. But it does maintain the vsync 60fps which makes it an enjoyable play.

                    2 of 2 people found this helpful
                      • Re: Crysis 3 huge FPS drops
                        shadowdevgamer

                        Thx, I will try it out, but even if it works it isn't optimal.

                        The reason for this is simple: When a mid-tier Nvidia card of the old generation (GTX 960 2GB VRAM) can

                        keep up 60fps while having the Game running with mid to very high settings than a high end current gen AMD card

                        (RX Vega 64) should be able to get the Game running on Ultra with constant 60 fps.

                        I basically mean currently you spend like 500 bucks more (where I live) on a Vega 64 while the cheaper GTX 960

                        runs with more fps.

                        So yeah, I hope this will get fixed.

                        • Re: Crysis 3 huge FPS drops
                          shadowdevgamer

                          I've tested it again and it turns out: Changing Shadows and Objects to low gives me fps higher than 60. There is still an fps drop on the same spots it existed before, but it never drops under 60 with those settings. Everything else was still set to the settings in the original post.

                          I've also updated the original post to contain a video showing the problem.

                      • Re: Crysis 3 huge FPS drops
                        locodicegr

                        Windows 10 Pro (1703, x64)

                         

                        Upgrade to 1803.

                          • Re: Crysis 3 huge FPS drops
                            shadowdevgamer

                            The truth is: I already tested it with 1709 and it made no changes, so why should the upgrade to 1803 suddenly change something?

                            I'm also on what was the business channel in 1703. Thus the upgrade to 1803 hasn't been rolled out for me.

                              • Re: Crysis 3 huge FPS drops
                                pokester

                                1803 is not rolled out officially for anyone. So no you should not use that. AMD does not support insider builds. You use those builds at your own risk. So I certainly would not introduce that version into a situation that already isn't stable.

                                 

                                I will check out Crysis 3 myself tonight. See what happens to me. Some games have a setting that my be physics heavy and be catered to nvidias drivers. Probably the best thing is to just change one setting at a time until you find the one causing issue. I am on an RX 580 so I will look into it and see if I can offer any help.

                                  • Re: Crysis 3 huge FPS drops
                                    hardcoregames™

                                    pokester wrote:

                                     

                                    1803 is not rolled out officially for anyone. So no you should not use that. AMD does not support insider builds. You use those builds at your own risk. So I certainly would not introduce that version into a situation that already isn't stable.

                                     

                                    I will check out Crysis 3 myself tonight. See what happens to me. Some games have a setting that my be physics heavy and be catered to nvidias drivers. Probably the best thing is to just change one setting at a time until you find the one causing issue. I am on an RX 580 so I will look into it and see if I can offer any help.

                                    1803 should be released fairly soon to the public, i am testing it now

                                    • Re: Crysis 3 huge FPS drops
                                      pokester

                                      Okay so I found the big ones that drop FPS on my RX580  they are Post Processing, Shading & Shadows. I had everything on very high and would drop to the mid 30's at times at 1440p. I took those three settings down one to high and frames now don't dip below 55 and mostly stay above 60. I can honestly say I saw Zero quality difference with those changes either. Game runs extremely well and smooth for me.

                                      1 of 1 people found this helpful
                                        • Re: Crysis 3 huge FPS drops
                                          hardcoregames™

                                          The RX 580 has lots of CU modules but many games with extreme rendering shaders can bog cards down a lot

                                           

                                          DX12 offers explicit dual card support but I am not sure which games work well with dual cards

                                            • Re: Crysis 3 huge FPS drops
                                              pokester

                                              Me either, from everything I read even most games with so called direct x 12 support aren't really from the ground up direct x 12 engines. I think we are still to see what maximum benefit we will have from Direct X 12. From what I read when Direct X 12 is done right that multi-gpu is native and doesn't even require any specific support, it is just kinda baked in unlike how crossfire worked. Apparently it even will work with cards from different makers like 1 AMD and 1 Nvidia card. It will be neat to see when it starts happening on large scale. My guess is that we will be a couple more gpu generations into the future before we really start seeing the real benefits. It definitely seems that traditional crossfire support has dropped off a lot in recent titles.