2 Replies Latest reply on Mar 10, 2018 5:47 PM by marekbujko

    Radeon 8700M Switchable Graphics card not being detected, cannot be seen in device manager, no drivers working

    hashani

      I've posted this same issue across several tech support subreddits and forums. Please, for the love of God, can anyone shed some light on what's going on?

       

      Recently, I noticed a dip in game performance and saw that games weren't detecting my Radeon 8700M card. Checking Device Manager, the card is not shown and all that is there is the onboard Intel 4000 graphics. 

       

      When right clicking the desktop or an app, I used to have an option from AMD for "Graphics Properties" or something like that, which would open the AMD Settings menu and let me change to High Performance and enable the card. This option isn't there anymore.

       

      I have the Samsung NP880Z5E with Win 10.

       

      This is what I tried at others' recommendation:

      1. Complete wipe/reinstall of windows

      2. Install all pending windows updates

      3. Install Samsung SW Update (their driver update utility tool)

      4. Saved all the setup files for pending drivers (there is a graphics driver included)

      5. Run through all driver installations

       

      The Radeon 8700M is still not shown throughout/after all of this. When running the Catalyst Install Manager included with the Samsung graphics driver update, all it does is install Catalyst Install Manager - nothing else.

       

      The card is not shown in dxdiag or hwinfo64. I tried launching Ubuntu from a pen drive, and the terminal there is not reading the AMD card either.

       

      Any advice? I've already wiped all my personal files in an attempt to get this working again, I'm getting desperate.