2 Replies Latest reply on Feb 26, 2018 10:51 AM by run

    Rx 550 No Signal

    run

      Hi.

       

      I recently bought a Rx 550 and when I plug it it doesn't relay any signal.

       

      • AMD Graphics Card
        • RX 550
      • Desktop or Laptop System
        • Desktop
      • Operating System
        • Windows 10 64bit
      • Driver version installed
        • Radeon Software Adrenalin Edition 18.1.2
      • Display Devices
        • HDMI 60Hz
      • Motherboard + Bios Revision
        • ASRock FM2A68M-DG3+; The lastest
      • CPU/APU
        • AMD A10 7700k
      • Power Supply Unit  Make, Model & Wattage
        • Corsair VS550
      • RAM
        • 8GB
        • Re: Rx 550 No Signal
          plumboby

          are your motherboard drivers in the pcie slot updated to accept the new videocard. Make sure you motherboard drivers are loaded up before trying to fire up your videocard. Download & run specy to check what drivers your missing & DDU to uninstall the Radeon drivers. You wanna make sure your motherboard will accept your card first. More details be nice to help answer a bit easier.

            • Re: Rx 550 No Signal
              run

              Thanks for the answer,

               

              If I put in the BIOS "Primary Graphics Adapter OnBoard", the GPU works but I can't play videogames with It because the Primary Graphics Adapter is OnBoard. With Rainbow Six Siege I can play with It without any problem because there's an option that allows me to choose which GPU to use.