1 Reply Latest reply on Mar 12, 2018 3:52 PM by ellisgl

    Win 10 x64 - B350 - RAID 1 (RCRAID) freezing

    ellisgl

      I upgraded from a FX-8350 (990FX chipset) to a Ryzen 1700 (B350) chipset (ASROCK AB350), installed Win 10 Pro x64 from scratch and I have been experiencing issues with Disk I/O hitting 100% and thus having 30 second to 2 minute freezes with anything dealing with disk I/O.

      Event viewer has this showing up under system when it happens:

      The description for Event ID 129 from source rcraid cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

       

      If the event originated on another computer, the display information had to be saved with the event.

       

      The following information was included with the event:

       

      \Device\RaidPort1

       

      And in application (source ESENT):

      wuaueng.dll (4224,D,0) SUS20ClientDataStore: A request to write to the file "C:\Windows\SoftwareDistribution\DataStore\Logs\edb.log" at offset 491520 (0x0000000000078000) for 4096 (0x00001000) bytes succeeded, but took an abnormally long time (36 seconds) to be serviced by the OS. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem

       

      Things I've done.
      Made sure all drivers were as updated.
      Made sure that the bios was updated.

      Changed caching modes of the RAID 1 array.

      Changed out SATA cables.

      Changed all the power settings in Windows (PCIe, HDD, etc) to make sure it's always on and never sleeps.

      Even RMA'd the motherboard - which ASRock went straight to doing when I reached out for support.

       

      Since the old system worked flawlessly with the SSD's (TRO-SSD7-1TB-PRO) in RAID 1 mode before upgrading, I don't think it would be the drives.

       

      Google searching of the issue has resulted in a quite a few people having this issue, but it seems more people haven't fixed it then have.

       

      Any suggestions?