0 Replies Latest reply on Feb 23, 2018 6:13 AM by georgi917

    Drivers for RX 550 for linux (ubuntu) refusing to work

    georgi917

      Hi guys,  I am asking this question here, because I am already out of ideas. So I bough new laptop Lenovo thinkpad e480 with the RX550 .

      It said linux supported, that is also the reason i bought it. Installed a linux mint 18.3 on it (based on ubuntu 16.04) And tried installing the amdpro 17.50 drivers.

      After the instalation, however it told me that grx render is not available, causing the desktop to crash all the time. So I tried everything on the forums:

      updating my xorg, installing with all options, changing the kernel, I noticed there is also a script in the 17.50 folder called amdgpu-install. I also tried it. It installed some mesa amd rendering, but

      installed also llvim, which desables 3d rendering. I tried this two scripts with 3 Kernels (4.10, 4.13, 4.15 (It is not supported i know)) and two operating systems Linux mint and kubuntu 16.0.4.3. Every time i get exactly the same result as before amdgpu-pro is not working at all amdgpu script is using llvim. Btw card is working fine on windows, had that checked. I would be very grateful if you could provide me with some hints, because  I have no idea what I am doing wrong. I can also provide you with some terminal outputs if necessary. Any help is appreciated!

       

      Regards

       

      Georgi