2 Replies Latest reply on Feb 20, 2018 11:17 AM by vandrunen

    Sapphire Radeon R9 390x Nitro black screen and no signal

    vandrunen

      Hello everybody.

       

      I've the Sapphire Radeon R9 390x Nitro since almost 2 years. A couple of weeks ago I encountered the first freezes during games. I still could hear people talking via skype and also the ingame sound. I never got back, so I had to do a restart. I couldn't find a fix and it happened randomly. The last time it happened it was kind of final. Since the last freeze, my monitor doesn't get a signal from the card anymore. I tried several different monitors, but I can't get a signal to the monitor at all. Not via DVI or HDMI. I used different cables too.

       

      I swapped with my old GPU and it worked fine. I also swapped it with a geforce gtx 1060ti from a friend and eveything worked fine.

       

      Anyone know a fix for this and/or has/had the same problem?

       

      My specs:

      Intel Core i7 4x400 Ghz So.1151 WOF

      GIgabyte GA-H17-D3HP Intel Dual Channel DDR4

      16GB (2x8192mb) Crucial DDR4

      530w Enermax Revolution XT Modular 80+ Gold

       

      8192 MB Sapphire Radeon R9 390x Nitro incl. Backplate Active

        • Re: Sapphire Radeon R9 390x Nitro black screen and no signal
          kiwinadians

          You are unfortunately in good company. Come check out this thread: Black Screen When Installing 17.12.2 Drivers HD 7870 Win 7

          I think your card is also from the Southern Islands era, and your symptoms are identical to what many others have experienced.

          There is no fix yet as far as we know.

           

          You can try the classic advice: reboot to safe mode, use DDU to clean drivers, boot back into windows, install new drivers. If that fails, try flashing mobo bios, and making sure onboard video (if you have it) is not being selected by your bios.

           

          I doubt that will fix the issue, as it doesn't seem to fix it for the rest of us. I have tried everything from flashing modified vbioses to running two gpus and seeing what error it throws. The error is just a Thread_stuck_in_driver error, which could mean a failing driver, or failed hardware. At this point, I am concerned that a recent windows/driver conflict has led our cards to either work at unsafe temps and fail, or has somehow allowed either an undervolt/overvolt scenario. I did run a gpu memtest (although this is known to not handle more than 1gb of memory) and got significant errors, meaning something could be happening to our ddr5 chips.

           

          At this point, it just seems like it is a waiting game until we get thrown a bone by either amd or microsoft. The reason I think it may be a hardware failure is that even going back to win 8.1 or 7 does not fix the problem, so something bad is going on.

           

          Come join us at the thread linked above!

            • Re: Sapphire Radeon R9 390x Nitro black screen and no signal
              vandrunen

              Thank you for your answer.

               

              I'm not sure if that post is the right one for me. I can't get a signal to any monitor from the gpu.

              The monitor turns off after a couple of seconds saying there is no signal. I tried everything DDU, windows, bios and onboard video.

              I can't install the drivers since I can't get any signal.

               

              I can't even tell if the gpu is dead. The fans are not running, but that's kinda normal isn't it? I mean since the card isn't hot at all.