AnsweredAssumed Answered

Installing AMD GPU Pro driver on Ubuntu 16.04.3 fails with Unable to locate package amdgpu-lib32

Question asked by jferrod on Feb 14, 2018

When I install the AMD Pro driver on Ubuntu 16.04.3 it fails with 'Unable to locate package amdgpu-lib32':

 

amdgpu-pro-17.50-511655$ ./amdgpu-pro-install

[sudo] password for xxxxx:

deb [ trusted=yes ] file:/var/opt/amdgpu-pro-local/ ./

Get:1 file:/var/opt/amdgpu-pro-local ./ InRelease

Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease

Get:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]

Get:2 file:/var/opt/amdgpu-pro-local ./ Release [814 B]

Get:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg

Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg

Hit:4 http://security.ubuntu.com/ubuntu xenial-security InRelease

Hit:5 http://ie.archive.ubuntu.com/ubuntu xenial InRelease

Hit:6 http://ie.archive.ubuntu.com/ubuntu xenial-updates InRelease

Hit:7 http://ie.archive.ubuntu.com/ubuntu xenial-backports InRelease

Reading package lists... Done                    

Reading package lists... Done

Building dependency tree      

Reading state information... Done

E: Unable to locate package amdgpu-lib32

E: Unable to locate package amdgpu-pro-lib32

 

Not sure what to do? How can I get these packages that it's looking for?

 

Note that this is on a 64 bit Ubuntu 16.04.3 installation, so it's a bit strange that it's looking for what seems to be 32 bit components.

Outcomes