1 Reply Latest reply on Mar 14, 2018 6:56 PM by l736x

    Heroes of the Storm DirectX problem

    l736x

      Dear Tech Support,

       

      Here is my system:

       

      AMD Graphic Card:

          AMD HD 7770

      Desktop or Laptop System:

          HP Pavillion H9-1110ef (Desktop)

      Operating System

          Windows 10 64bit updated

      Driver version installed

          The problem showed up from early november 2017 to today, and I kept the drivers updated, so all the versions from Crimson 17.7.2 up to Adrenalin 18.2.1

      Display Devices

          Benq GL2450HM, HDMI, 1920x1080 @60

      Motherboard + Bios Revision

          Pegatron IPMMB-FM, Bios Version 8.21

      CPU/APU

          Intel i5-3450

      Power Supply Unit  Make, Model & Wattage

          Sorry, no idea ...

      RAM

          8 GB

       

      Issue:

       

      I own an HP Pavillion H9-1110ef desktop with an AMD HD 7770 gpu.

       

      After having played Heroes of the Storm (a MOBA, not the most demanding title out there!) for a couple of years, since more than three months now I've been having problems.

      Quite regularly, a few minutes into a match, I am disconnected for a brief period (let's say from 2 to 10 seconds) and when the game comes back there are some graphical artifacts that make the game difficult to play.

      In the worst cases the game client crashes and a couple of times I got a BSOD.

       

      I already tried most of the troubleshooting suggested by blizzard:

      - Updated the graphic drivers (several times in these three months)

      - Scan and repair the game

      - Tried Selective Startup

      - System file checker

      - ScanDisk

      - Security scan

      - Memory diagnostic tool

      - Ran WinMTR: see result below

       

      The relevant part of the game log is here and it points to a DirectX problem:

       

      GFX  01:12:04.958 Resource Cache Texture: 950MB

      GFX  01:12:04.958 Resource Cache Texture Used: 0MB

      GFX  01:17:56.550 Focus Event. Changing to windowed.

      GFX  01:17:57.576 Focus Event. Changing to fullscreen.

      GFX  01:18:41.031 DirectX call  failed with error code -2005270523

      GFX  01:18:41.032 PerfNotifier: [Render] [APIErrors] Occurrences [1] Peak [1.000000]

      GFX  01:18:41.170 Attempting device reboot

      GFX  01:18:41.680 Final device refCount is 0

      GFX  01:18:41.680 Adapter "AMD Radeon HD 7700 Series" Vendor 0x4098 Device 0x4098

      GFX  01:18:41.680 Adapter "Microsoft Basic Render Driver" Vendor 0x5140 Device 0x5140

      GFX  01:18:41.680 Skipped adapter "Microsoft Basic Render Driver" because no ouputs

      GFX  01:18:41.680 Attempting D3D11 device creation on "AMD Radeon HD 7700 Series"

      GFX  01:18:41.698 Device creation success.

      GFX  01:18:41.698 Setting up swap chain.

      GFX  01:18:41.698 Trying fullscreen

      GFX  01:18:41.753 Found matching display mode width: 1920 height: 1080 RRN: 60 RRD: 1

      GFX  01:18:41.754 Resizing D3D11 swap chain (1920x1080)

      GFX  01:18:41.958 Windows Timeout Detection and Recovery (TDR) detected!

      GFX  01:18:42.278 Device reboot successful

      GFX  01:18:44.426 PerfNotifier: [Render] [DeviceReboots] Occurrences [1] Peak [1.000000]

      GFX  01:18:44.426 PerfNotifier: [ResourceCache] [Evicted] Occurrences [1] Peak [162.062500]

       

      The graphic card is not overclocked.

      I stress-tested it intensively and never got the slightest problem.

      During the games the temperature does not exceed 65 degrees, while under stress test it reached and passed 75.

       

      I tried to run with -dx9 but the problem persisted.

      I tried to deactivate the windows blue light overlay ("night light") but again the problem persisted.

      I tried to lower all the graphic settings to low. It takes longer but in the end the problem shows up again.

       

      I also run a DxDiag and the interesting part seems this:

       

      ---------------

      Diagnostics

      ---------------

       

      Windows Error Reporting:

      +++ WER0 +++:

      Fault bucket LKD_0x141_Tdr:6_IMAGE_atikmpag.sys, type 0

      Event Name: LiveKernelEvent

      Response: Not available

      Cab Id: 8ab84fb9-82fc-4088-b2bd-d7a186a7643e

       

      Problem signature:

      P1: 141

      P2: ffffcc8766cee010

      P3: fffff809b2d0ccec

      P4: 0

      P5: 2004

      P6: 10_0_16299

      P7: 0_0

      P8: 768_1

      P9:

      P10:

       

       

      +++ WER1 +++:

      Fault bucket , type 0

      Event Name: LiveKernelEvent

      Response: Not available

      Cab Id: 0

       

      Problem signature:

      P1: 141

      P2: ffffcc8766cee010

      P3: fffff809b2d0ccec

      P4: 0

      P5: 2004

      P6: 10_0_16299

      P7: 0_0

      P8: 768_1

      P9:

      P10:

       

       

      +++ WER2 +++:

      Fault bucket 2215936887271652712, type 5

      Event Name: BEX64

      Response: Not available

      Cab Id: 0

       

      Problem signature:

      P1: RadeonSettings.exe

      P2: 10.1.2.1703

      P3: 5a287154

      P4: StackHash_ac46

      P5: 0.0.0.0

      P6: 00000000

      P7: PCH_68_FROM_ntdll+0x00000000000A09C4

      P8: c0000005

      P9: 0000000000000008

      P10:

       

      More content can be found in the original thread on the Blizzard forum:

       

      https://us.battle.net/forums/en/heroes/topic/20761067675

       

      (Notice that the Blizzard support suggested posting on this forum.)

       

      Thanks in advance for your help!

       

      Cheers