AMD Switchable Graphics not Utilizing my R9 M385X (Lenovo Y700-15ACZ)

Discussion created by thepunysirlittleturd on Feb 11, 2018
Latest reply on Jan 5, 2020 by flomsku

Games and other applications do not utilize the discrete graphics card on my laptop.


Using Windows Device Manager, Speccy, CPU-Z, or GPU-Z, both my R6 Graphics and my R9M385X Graphics are visible.


Laptop Power Plan is set to High Performance, have tried setting graphics profile in Radeon Settings to both Optimize Performance and Optimize Graphics Quality and received no change.


Applications in Radeon Settings have been manually set to run in High Performance mode (as opposed to Power Saving or Based on Power Source) to no avail.


UEFI Graphics settings are set to Discrete.


Despite this, when using CPU-Z, GPU-Z, or Windows Resource Monitor to monitor system load, the R9 does not receive any system load whatsoever. Only when running a Render TEst with GPU-Z can I see any system load being placed on the R9. Additionally, Games that give me the ability to choose my display adapter present the AMD Radeon R6 Graphics as the only option.


I have tried uninstalling ALL AMD Drivers, Performing a clean uninstall by using the DDU tool, and installing the newest compatible AMD drivers, this has not changed.


Every 3 or 4 weeks, I will receive a warning notification in Radeon Settings that my Crossfire bridge is not properly connected, but until recently though nothing of this (because as far as I knew, my iGPU and dGPU do not utilize a crossfire bridge in order to work, and my system still detected both Display Adapters). It should be noted that the warning is not consistent upon every boot of the device, and appears randomly.


DxDiag and Speccy Summary are attached, and I will be more than happy to attach any other required documentation.