AnsweredAssumed Answered

Radeon 7730M - BSOD after installing AMD Software

Question asked by pfelipe23 on Feb 10, 2018
Latest reply on Aug 8, 2018 by tahadj

Hello everyone!

 

Few days ago (maybe Feb 5) I was notified by AMD Radeon Software that was a new driver available (i.e. 18.2.1) for my device (i.e. Radeon HD 7730M), and then I started the driver upgrade.

My nightmare starts here: During the installation (on "video card driver" point), everything froze! I tried to restart (after 30 minutes waiting), but when Windows started, the BSOD happened: "THREAD_STUCK_IN_DEVICE_DRIVER".

 

"Okay, I'll uninstall this driver with DDU on safe mode and re-install the last driver (I don't remember exactly the driver's version, but I think it was 17.2.X)." - I thought...

 

I tried to install the 17.2.1: Everything froze during installation, BSOD on restart.

 

"Maybe there's some junk on registry, let's format all C drive..." - I thought.

 

Resuming: I re-installed the Windows and deactivated the GPU driver update on Windows Update, and it keeps freezing and giving me BSOD when I try to install any AMD Software (I tried the last release of 15, 16 and 17 series, and the 18.2.1).

 

Now I have the full system up to date (some drivers updated via Drive Booster 5), Windows with no updates available, and a restore point called "LastStable" just in case...

 

How can I solve this issue?

 

System Specifications:

  • AMD Graphics Card
    • AMD Radeon HD 7730M.
  • Desktop or Laptop System
    • Dell Inspiron 15R SE (7520).
  • Operating System
    • Windows 10 Home 64-bit.
  • Driver version installed
    • Radeon Software Adrenalin Edition 18.2.1.
  • Display Devices
    • Default notebook display (1920 x 1080).
    • LG Flatron W1752T, connected in VGA (1440 x 900).
  • Bios Revision
    • A11 (the last available on Dell's website)
  • CPU/APU
    • Intel i7 3632QM, 2.2 GHz (Intel Turbo installed, it goes up to 3.2 GHz).
  • RAM
    • 16GB, DDR3, 1600 MHz.

Outcomes