7 Replies Latest reply on May 2, 2018 11:36 AM by fabb1973

    RADEON HD 5870 problem with windows updates in windows 7 SP1

    fabb1973

      SPECS:

       

      Video Card: RADEON HD 5870 2gb (Asus Matrix version)

       

      Driver: non-whql-64bit-nieg-radeon-crimson-16.2.1-win10-win8.1-win7-feb27.exe  (last one for this card)

       

      Mobo: Gigabyte X58A-UD3R rev 1 (00)

       

      Displays: 1- LG TV through HDMI cable (1920 x 1080 res) + HDMI AUDIO only   2- Samsung SyncMaster T220 through stock connection (1680x1050 res)

                          Display 2 is the startup system display device.

      OS: Windows 7 SP 1 with all actualizations for 2017 through Windows Update with no problems until:

             Security and Quality Rollup for .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, and 4.7.1 updates for Windows 7 SP1 and Server 2008 R2 SP1 (KB 4055532) .......and all updates refered to .NET Framework or refered to display graphics direct or indirect way (I installed several updates all 2017 about .NET in all of its versions and never had a single problem)

       

      * System Restore at point before updating to revert any problem.*

       

      Problem: When system restarts after this updates (or updates related) can´t recognize video driver appearing like never was installed, or was deleted or unrecognized by OS displaying with default min resolution (1024x768), no catalyst panel, no trace of existence of driver in the OS. The rest of the system runs perfect (creative audio, programs, system, modem, archives, etc etc etc)

       

      Solutions tried:

       

      1- Scanned with anti spywares, antivirus updated in deep scan for malware, virus, spam, etc etc etc etc before updating

      2- Deactivating all running programs including antivirus before upgrading, with a special tool (Process Explorer) that detects any possible event or program running on system that is not essential for the task

      3- Shut down and wait several minutes and start system

      4- Restarting several times expecting any error message or fixed startup

       

      Had no problems until that updates, no problems with games, no problems with aplications, updates or HD movies, media, etc etc etc (related to video card or video driver). Performance is great for anything not related to some extra "heavy" ultimate games, nothing else.

       

      Anyone had video driver problems updating windows 7 SP1 with this 5000 series (driver gone after update), specially .NET framework (actual versions)? If that so, could be helpfull the solution.

       

      (no solutions: format system, change OS or change video card).

       

      Thanks for reply