11 Replies Latest reply on Feb 10, 2018 3:05 PM by blueo

    ATI Radeon Pitcairn HD 7850 driver reverts to ATI Radeon 3000 graphics

    blueo

      I bought a ATI Radeon Pitcairn HD 7850 2GB DX11.1 and installed it monhts ago. Updated driver and it worked fine.

       

      Had a couple of occasions where I turned on my computer and had a black screen. Plugged VGA into motherboard and got it to work - went onto the device manager and saw that the driver listed for my card had changed from the 7850 one to ATI Radeon 3000 graphics. Last time I installed several different packages and it worked but in the last week it has reverted again. Whenever I try to get it to update it just stays on the 3000 version. I tried reinstalling it by following the part of the AMD website where it asks for your card and gives you the package to download but this has not worked.

       

      I'm running Windows 10. 64bit

       

      to add:

       

      I used the DDU tool to remove everything and when i tried to reintall, I got a message saying "Components already installed".

       

      edit 2:

       

      I went onto BIOS and switched it to PEG. Loaded up and my card still says the Windows basic adapter. Tried installing the Minimal set up Radeon software and once it had finished and scanned it came up with "Components are already installed" again. Tried shutting down and plugging in through my GPU and got black screen.

       

      Went back on and updated my device, selecting the location of the downloaded AMD drivers program and each time it installed the ATI Radeon 3000 graphics driver. I can't see any way of manually updating it with the correct software.