4 Replies Latest reply on Feb 7, 2018 4:43 AM by kingfish

    Drivers problem. Can't Unistall old version, can't install new version.

    zmachol

      For 2 days I am experiencing system crashing while trying to run games. I was trying to update the drivers (v 18.2.1) but it didn't help. Then i tried to update the drivers through the windows update center, and it has installed 17.5 version (wth?), so i decided that i want the newer version (17.12.1). Now, guess what? I cant unistall 17.5 version. Even if i install newer version the instalator goes, and finishes work and then tell me it's done, but when i run amd settings and check the version it still shows 17.5 wth? Then i tried to clean Up everything and install the 17.12 version on clean computer, but it didnt work too. what's the matter?

      Graphics: AMD R9 375
      Driver: none for nowLaptop: Lenovo Z51

      OS: Windows 10 64 bit

      CPU: intel i5 - 5200U

      RAM: 8GB

        • Re: Drivers problem. Can't Unistall old version, can't install new version.
          zmachol

          Radeon Settings Version - 2017.1206.1740.31787

          Driver Packaging Version - 17.50.02-171206a-321058C-RadeonSoftwareAdrenalin

          Provider - Advanced Micro Devices, Inc.

          2D Driver Version - 8.1.1.1634

          Direct3D® Version - 9.14.10.01316

          OpenGL® Version - 6.14.10.13506

          OpenCL™ Version - 23.20.15002.11

          AMD Mantle Version - 9.1.10.0237

          AMD Mantle API Version - 102400

          AMD Audio Driver Version - Not Available

          Vulkan™ Driver Version - 2.0.1

          Vulkan™ API Version - 1.0.65

           

          Graphics Card Manufacturer - Powered by AMD

          Graphics Chipset - AMD Radeon (TM) R9 M375

          Device ID - 6820

          Vendor ID - 1002

          SubSystem ID - 3824

          SubSystem Vendor ID - 17AA

          Revision ID - 81

          Bus Type - PCI Express 2.0

          Current Bus Settings - PCI Express 2.0 x4

          BIOS Version - 015.048.000.069

          BIOS Part Number - BR46647.001

          BIOS Date - 2015/12/02 00:17

          Memory Size - 2048 MB

          Memory Type - DDR3

          Memory Clock - 900 MHz

          Core Clock - 1015 MHz

          Total Memory Bandwidth - 28 GByte/s

          Memory Bit Rate - 1.80 Gbps

          2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001

           

          And beside this, still when i go to the updates zone, i can still see that the version is 17.5, despite i have just 5 mins ago I have installed 17.12 and the installer told me it was succesfull wth? It doesn't work even if i try to update it through the "updates" zone in Radeon Settings app. How can I solve this problem?

          PS: I have tried both : 'express' and 'custom' upgrade sooooo...