AnsweredAssumed Answered

Windows 1- FCU Keeps Downgrading My AMD Drivers - Radeon HD 7730m

Question asked by leofbrj on Feb 3, 2018
Latest reply on Mar 25, 2018 by grpronk

Hi everybody!

I have a Dell Inspiron 7520 notebook, with a dedicated AMD Radeon HD 7730m, with Windows 10 (always kept up-to-date, I mean Fall Update is installed, etc).

3 weeks ago I noticed a FPS drop while playing War Thunder, same happened with other apps. If I remember correctly no update was installed at that time (WT, AMD or Windows), everything began abruptly.

Updated the Intel 4000 driver. Nothing.

The AMD driver was up-to-date, so I uninstalled it with the AMD tool (also tried DDU many times) and reinstalled it. It worked, but after restarting the OS everything turned back as before. By the way, I wasn't even able to start AMD Settings.

Then I realized Windows Updated was installing an old version of the driver (a 2015 version, I don't actually recall the exact number) over the recent version I had just installed. I disabled with the specific tool that specific update. But nope!

Now, here's the situation: checking Device Manager it says that the latest driver is installed (17.12, the WHQL). BUT, if I open AMD settings (thank God at least this works now) it says that version 17.50ecc version is installed at the moment. And this definetely gives me awful performances with many apps. I can re-install the driver, but after Windows reboot... meh.

So, the question is: what kind of sorcery is this? I've looked for solutions on this and other forums, it seems I'm not the only one having this issue, but I really can't understand what's wrong with this...

 

Thanks for your help

 

Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.

Outcomes