6 Replies Latest reply on Mar 15, 2018 4:18 AM by perzosek

    Sapphire Pulse Radeon RX550 has code 43 error

    sirrah

      I have installed a Sapphire Pulse Radeon RX550 4GD5 graphics card in a Dell Optiplex 950 Windows 10 x64 Desktop computer. Intel Core™ Quad CPU Q9650 @ 3GHz and 8GB RAM.

      However, under Display Properties it shows that only the Microsoft Basic Display Driver is installed. I have repeatedly reinstalled the driver software, uninstalling and rebooting first. I also tried installing in Safe Mode, but the installer won’t run in Safe Mode. Each time, the installation appears to succeed but, although the AMD installer shows that I currently have version 18.1.1 installed, Windows still shows the Microsoft Basic Display Driver. Also, the Radeon system tray icon shows the message: “Radeon settings are currently not available. Please try again after connecting AMD graphics”, when clicked. I have checked that the card is inserted correctly and that the fan is running.

      Device Manager shows Radeon RX 550 Series under the Display Drivers heading but it has a yellow warning triangle on it. The Device Status is “Windows has stopped this device because it has reported problems. (Code 43)”.  I have tried this with various versions of the AMD software: 17.7.2, 17.11.1, 17.12.1, 17.12.2 and 18.1.1, which is currently installed).

      Some advice on how to have the PC recognise the installed drivers would be most appreciated.

      Thanks